Firmware 3.105 Snapshot Update

This should already be in the firmware. Adguard is only in some models which is powerful enough.

thanks @alzhao for the response.

I did not mean adguard home.

I mean please add adguard dns and quad9 dns to the list of DoT options.

Currently the choice is Cloudflare or NextDNS only on beta1 firmware.

I hope that is clearer now.

thanks again.

I see. But you can use DNS https proxies which is just below DNS TLS.

You mean dnscrypt-proxy?

The version included in the firmware is a bit out of date and quad9 is not available on the list unfortunately.

I just wanted easy quad9 encrypted dns and your DoT option seemed the simplest way to get it.

Local subnet communications won’t even touch the router interface so there’s nothing for wireguard to do here. Maybe I’m misunderstanding your issue?

Its nice to see the new transparent way of gl firmware development. For more ideas of possible improvements, pls check the open points from:

I just “upgraded” from 3.104 > 3.105 beta2 and NextDNS over TLS doesn’t appear to work. I entered my ID and it fails. To get it to work I had to edit the stubby.yml manually.

Edit: AR300M

I am using MT300N-V2 and NextDNS just works.

I just re-tested and although I get NextDNS, I do not get my specified ID.

I tested 300m NAND and NOR, and using Nextdns +ID worked normally.
Are you upgrading from the previous version of the reserved configuration?

I installed Tor in two device Mt300-v2 without rom space problem, but in the first Tor function correctly, in the second not bootstrap when I start the app.
See log msg below:
/usr/sbin/tor status

Error loading shared library No such file or directory (needed by /usr/sbin/tor)
Error relocating /usr/sbin/tor: evdns_set_log_fn: symbol not found
Error relocating /usr/sbin/tor: event_active: symbol not found
Error relocating /usr/sbin/tor: evdns_base_resolve_ipv4: symbol not found
Error relocating /usr/sbin/tor: event_config_set_flag: symbol not found
Error relocating /usr/sbin/tor: evdns_set_random_bytes_fn: symbol not found
Error relocating /usr/sbin/tor: event_base_loop: symbol not found
Error relocating /usr/sbin/tor: evdns_server_request_add_a_reply: symbol not found
Error relocating /usr/sbin/tor: event_get_version: symbol not found
Error relocating /usr/sbin/tor: evdns_base_set_option: symbol not found
Error relocating /usr/sbin/tor: event_config_set_num_cpus_hint: symbol not found


Yes, I saved settings - will try again doing a clean install.

EDIT: OK, a clean install fixed it - thanks for your help!

I’m thrilled that this is working again as I’m able to tether via USB to my iPhone 12 Pro Max. I’ve made the following observations on throughput:
Mac → Ethernet → GL → USB → iPhone: 50Mbps down
Mac → Ethernet → GL → 5GHz WiFi → iPhone: 92Mbps down
Mac → 5GHz WiFi → iPhone: 220Mbps Mbps down
iPhone: 230Mbps down

I’ll say that it seems throughput is bottlenecked through the GL to ~50Mbps via USB and ~90Mbps via WiFi. On the iPhone the same speed test yields 250Mbps. Hoping someone from GL notices this and can look into it. Again, it’s great progress to have this working again, thanks!

1 Like

Version 3.105 has been released and updates can be detected in the router for the following models:
Thanks for helping with the test.


there’s some issues triggering update from goodcloud.
currently MT300N-V2 on 3.102, when selecting upgrade, it detects newer version named “V2”, and then it won’t upgrade.
AR750S, on an older testing firmware number 3.105, unable to upgrade to final 3.105.


Seeing the exact same issues with the MT300N-V2 on 3.102 and not updating on goodcloud.
Also the MV1000 doesn’t have 3.105 showing yet.

Current Version


Compile Time

2020-08-27 18:19:40

Last Update


Maybe because of this?

Tue Dec  8 16:06:33 2020 : api:/router/running/state.
Tue Dec  8 16:06:33 2020 daemon.err gl_mqtt_cli[6660]: cat: can't open '/etc/glproduct': No such file or directory
1 Like

There are some problems with my automatic version generation rule, I have manually adjusted the version number from V2 to 3.105.
To upgrade from the test version to the latest version, you can download the latest 750S firmware here and upload it manually

Just so people are aware, 3.1.05 both public and testing releases break Softether installation.

This will be because it relies on which gets upgraded.

The error looks like this for anyone searching the forum

Error loading shared library No such file or directory (needed by /usr/libexec/softethervpn/vpnserver)

1 Like

A new version of Softether will need to be recompiled and linked with the newer OpenSSL version. @luochongjun