Firmware 3.201_beta3

Updated, beta6 is here
There is a new APP that works with 3.201. Welcome to try it.
iOS TestFlight: Join the glinet beta - TestFlight - Apple
Google Play Beta: https://play.google.com/apps/testing/xyz.goodcloud.glinet


I put 3.201_beta3 in the here, you can download the test if you need to, 3.201 is expected to be released on March 31st, it is now in beta, there may be stability issues, so if you are a completely inexperienced user, please do not try.

Note that some models include *.img and *.tar, where *.tar is used to upgrade the admin page and *.img is used to upgrade the uboot. In general, you should download the *.tar file

ReleaseNotes

System:
Based on openwrt 19.07.7  (AR150,MIFI,AR300M,USB150,N300,AR750,AR750S,X750,E750,X1200,XE300,MT1300,MT300N-V2,MV1000)
Based on QSDK11  (B1300,S1300,AP1300)

Security:
1. Fixed wolfSSL heap buffer overflow in RsaPad_PSS (CVE-2020-36177)
2. Fixed netifd and odhcp6c routing loop on IPv6 point to point links (CVE-2021-22161)
3. Fixed dnsmasq multiple vulnerabilities (CVE-2020-25681, CVE-2020-25682, CVE-2020-25683, CVE-2020-25684, CVE-2020-25685, CVE-2020-25686, CVE-2020-25687)
4. Added times limit to password authentication

New features:
1. Supported IPv6 ( Internet, OpenVPN, WireGuard )
2. Supported WPA3 (AR150,MIFI,AR300M,USB150,N300,AR750,AR750S,X750,E750,X1200,XE300)
3. Supported deleting offline clients
4. Added warnings when uploading old version or three-party firmwares
5. Added 2.4G WIFI and LTE working channel interference automatic avoidance
6. Supported IGMP (AR150,MIFI,AR300M,USB150,N300,AR750,AR750S,X750,E750,X1200,MT300N-V2,B1300,S1300,AP1300,MV1000)
7. Supported DLNA (AR150,MIFI,AR300M,XE300,AR750,AR750S,X750,E750,X1200,MT300N-V2,B1300,S1300,AP1300,MV1000)

Software Upgrade:
1. Upgraded AdGuardHome to 0.104.3(MV1000,S1300,AP1300

Hardware support:
1. Supported SPI nand GD5F1GQ5UEYIG

Optimization:
1. Optimized client statistics function

APP support:
1. Supported V1.0.5

Cloud support:
1. Supported Rtty SSH Access(MIFI,XE300,X300B,AR750S,E750,MT1300,X750,X1200,B1300,S1300,AP1300)
2. Supported Rtty HTTP Access(MIFI,XE300,X300B,AR750S,E750,MT1300,X750,X1200,B1300,S1300,AP1300)
3. Supported Ping tool(XE300,X300B,AR750S,E750,MT1300,X750,X1200,B1300,S1300,AP1300)
4. Supported Traceroute tool(XE300,X300B,AR750S,E750,MT1300,X750,X1200,B1300,S1300,AP1300)
5. Supported RS485 tool(X300B)

Language:
1. Supported Russian

Important bugfix:
1. Fixed speed limit function failure in some models
2. Fixed tor initialization failure in some models
3. Fixed the problem that when turn off the AP in MT300N-V2, the repeater won't auto-reconnect.
4. Fixed the problem that when WireGuard's Allowed IPs are not set with global proxy address, router will be unable to access the internet. 
5. Fixed the problem that MT1300 can't access internet when using StrongVPN.
6. Fixed other known issues.
4 Likes

Any problems in the trial process, please feedback here, I will deal with in time.

How does one load this firmware, as I tried an “unofficial” build (Snapshot 3.201 "Upgrade" Woes) and it was a nightmare.
This morning tried the beta 2 and had the same problems - flash seemed to go OK but router wouldn’t boot.
So am I right in thinking this is for Uboot only or is it just me (my router)?

Hap
(AR300M)

There is a folder named 2B, what does that mean?

MT1300 here. LuCI fails to install, perhaps because the repositories are broken. I had the same problem with 201.2-27. The Advanced tab is showing, but when you click on it it says LuCI failed to install. Here is the same thing from an SSH session:

BusyBox v1.30.1 () built-in shell (ash)

| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
|
_____|| |
||||___||| |____|
|
| W I R E L E S S F R E E D O M

OpenWrt 19.07.7, r11306-c4a6851c72

root@GL-MT1300:~# opkg update
Downloading https://fw.gl-inet.com/releases/v19.07.7/packages-3.0/ramips/packages/Packages.gz
*** Failed to download the package list from https://fw.gl-inet.com/releases/v19.07.7/packages-3.0/ramips/packages/Packages.gz

Downloading https://fw.gl-inet.com/releases/v19.07.7/packages-3.0/ramips/glinet/Packages.gz
*** Failed to download the package list from https://fw.gl-inet.com/releases/v19.07.7/packages-3.0/ramips/glinet/Packages.gz

Downloading https://fw.gl-inet.com/releases/v19.07.7/kmod-3.0/ramips/mt7621/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_kmod
Collected errors:

Downloading https://fw.gl-inet.com/releases/v19.07.7/packages-3.0/ramips/glinet/Packages.gz
*** Failed to download the package list from https://fw.gl-inet.com/releases/v19.07.7/packages-3.0/ramips/glinet/Packages.gz

Downloading https://fw.gl-inet.com/releases/v19.07.7/kmod-3.0/ramips/mt7621/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_kmod
Collected errors:

EDIT: This is true after a factory reset also.

When an OpenVPN client is connected, the shield on the main Internet page shows and exclamation point and not a check mark. (when a wireguard client is connected, it correctly shows “wg”).

EDIT: This is true after a factory reset.

Use vi to edit /etc/opkg/customfeeds.conf, add in the repos for 19.07.7

src/gz Base https://downloads.openwrt.org/releases/19.07.7/packages/mipsel_24kc/base
src/gz Luci https://downloads.openwrt.org/releases/19.07.7/packages/mipsel_24kc/luci
src/gz Packages https://downloads.openwrt.org/releases/19.07.7/packages/mipsel_24kc/packages
src/gz Routing https://downloads.openwrt.org/releases/19.07.7/packages/mipsel_24kc/routing
src/gz Telephony https://downloads.openwrt.org/releases/19.07.7/packages/mipsel_24kc/telephony

luci will give some errors, but i ignore them and it still works.

@luochongjun When can we expect a working repository?

hello,

has gl-inet been hacked?
my web browser is freaking out.


Thanks. That worked. The standard repos throw errors but Luci installed.

In LuCI the status syntax errors are still present {as they were in 201b1 and 2}

No, there just isn’t HTTPS on that specific url, it is the old one, and your browser/extensions are set to HTTPS only.
I don’t know why @luochongjun is using that link. Here is the correct one:

https://dl.gl-inet.com/firmware/snapshots/3.201_beta3/

I edited his link as well.

1 Like

thanks much, that works

1 Like

Has the VPN Policies issue been fixed in this Beta?

Thank you.

Hi there,
what about wpa3 in mt300n-v2 (mango).
It does not appear as option in the select dropdown (checked as both AP and repeater).
It seems an option in ar750 (creta) with the new firmware.
Thanks.

Another issue with mt300n-v2 (mango) is AP speed. Wan port providing >100 mbps, so this is no issue.
When using 3.105 I used to get 40-50 mbps, now with the same params 12 mbps in 3.201 beta2 and snapshot 2021-03-18.

We have a new APP that works with 3.201. Welcome to try it.
iOS TestFlight: Join the glinet beta - TestFlight - Apple
Google Play Beta: https://play.google.com/apps/testing/xyz.goodcloud.glinet

This issue has just been fixed in the Beta3 version. You can re-download the Beta3 version and upgrade via uboot.
http://download.gl-inet.com.s3.amazonaws.com/firmware/snapshots/3.201_beta3/ar300m/openwrt-ar300m-3.201-0317.img
https://docs.gl-inet.com/en/3/troubleshooting/debrick/

1 Like

This is for business users and relies on Glinet’s cloud platform, which is not available to individual users.

I have corrected the path of the software library.
The error message of the Luci page has been corrected in the new software library. You can try the reset firmware and reinstall Luci.

1 Like