Firmware 4.2.1 makes WiFi unstable on AX1800

I upgraded the 3.x version to a newer 3.x version via the online method and then to 4.2.0 and then 4.2.1 manually. What I experience now with the newest firmware is that both 2.4 and 5Ghz WiFi signals become unstable after a while and connections to both LAN and WAN destinations won’t work anymore after a while and ping time become huge. A simple - but annoying - solution is to reconnect the wifi.

This doesn’t happen at all with the same laptop device on another wifi access point in my home.

Did you update U-boot version?

This could be unrelated to your recent update to newer firmware. I noticed the same issue with WiFi disconnects about two days ago (only one 5G network used). I just checked my firmware and noticed it was on an older version - 3.x (I know, horrible security on my part). So apparently the older version also has this problem, at least in my case.

I’m updating to the latest version and also enabling auto-upgrade, lest I forget to check it for another 6 months again. I’ll be checking this thread daily to see if any solution to the WiFi disconnects, and also to report if my AX1800 is experiencing them again.

I’ve done the upgrade to 4.x using the online method, so I guess that should be yes to your question? The other minor upgrades I did manually, not using the uboot version which also wasn’t necessary I read

I also already restarted the router as an attempt to solve the issue btw.

Uboot must be upgraded manually
After you will need to do a complete fresh install of the firmware.

Please ssh into flint and use this command to verify the uboot version:

strings /dev/mtd7 |grep "U-Boot 2"

Mine says: Uboot 2016.01 (July 10 2022 - 23:27:05 -0400) is version 22.10.07 (year,day,month)

1 Like

U-Boot 2016.01 (Dec 01 2021 - 20:16:45 +0800)

I bought a tp-link T3U wifi adapter and I don’t seem to have the same issue so far. So it only seems to be with my internal Intel Wifi6 chip. If this keeps working, I’ll have the chip replaced.

Your uboot is the older version 21.01.12
There is a bug with U-Boot causes random issues with the upgrade process from 3.x to 4.x Firmware

So is this recommended for all AXT1800 models with the 21.01.12 version.

Yes it is recommended for the GL-AXT1800 Slate AX and the GL-AX1800 Flint. Make sure you are using the page and not

Bottom of tutorial there is a expand section that says Upgrade the U-boot Version with instructions

1 Like

This doesn’t work though. The uboot update always fails (I tried different versions) and complains about wrong file size of something about ART on a device with unknown FLASH. I verified the hash of the .img file and it’s as advertised on the download page

Edit: I managed to perform the uboot upgrade, although it was quite confusing on how to do it.

This was the uboot file needed for AX1800: uboot-ipq60xx/uboot-gl-ax1800-20220711-md5-9890c67c3dafa5aec172f3a31583f9a7.bin at master · gl-inet/uboot-ipq60xx · GitHub and had to be uploaded via as mentioned before.

Then I updated the firmware from the website (I also downloaded the uboot version) via the same method but via and applied the config.

Let’s see if this solves my wifi issue.

Edit 2: it’s not solved. I think it might be a software issue (Manjaro) on the client side. I’ll investigate further on that side. Thanks for the help!

It’s actually not a client side thing AFAICS because wifi works without any issue on other router devices. Somethings wrong with my AX1800 device after all

Can you let me know if all clients have problems or just one?

When there are problems can you export the log from the router to check?

It happens with my laptop, but not with my Android phone AFAIK. I’m gonna keep an eye on it whether my housemate experiences the same with her laptop

I’ll try to get the logs next time.

So everything is up to date, try turning off Disassociate On Low Acknowledgement
located in the LuCi Wireless menu. Click edit for the wireless SSID it is disconnecting from, go to interface configuration and click the advance settings tab will be bottom of page.

I am finding 5Ghz is unstable, specifically for Nintendo products. We have a few Nintendo Switches here and they all seem to be unable to connect to the 5Ghz network they were connected to previously on 4.2.0.

Hi,Is it the Nintendo switch that can’t detect 5G WIFI? Or failed to connect to 5G WIFI?

It detects cannot connect, whereas a ipad can. Its very strange. I have two devices both have issues after this update.

should solve the problem

Just to confirm, no disconnection problems after I updated the firmware to latest version.