Firmware 4.2.x is out as snapshot firmware

Tried on a first gen Beryl. iPhone won’t stay connected to the wifi. Rolled back to stable.

On MT3000, AXT1800, country code is preconfigured.

So in Japan, the country code is JP already.

@alzhao, for me this is not quite correct, I got my MT3000 delivered to me here in HK, I was not asked *but also did not ask) for a specific country configuration, but the Admin Page has a little “US” symbol at upper left and the Country Code in the Luci Webadmin shows 00, see GL-MT3000 Beryl AX - No Country Code Option in Luci? - #2 by Almahadeus.

When I went into etc/config/wireless it showed “US”. Was I sent the wrong model or does HK get the US model by default? [EDIT] Sent an email to support as well.


We didn’t put a HK country code there. In HK it is US version.

OK thanks for the heads up, but US codes are 1-11 only and HK is 1-13, two more channels than the US.

I intend to use this Router in Travels to all of Germany and NZ and possibly the UK; all three are also 1-13 according to What channels are supported in both the 2.4 GHz and 5GHz band in most countries?.

I understand I can change this using SSH access to etc/config/wireless but this is beyond the average user; the ability to (continue to) modify it in the admin page would be appreciated.

1 Like

There is always a tradeoff.

By regulation users cannot change country code in the UI.
But when you travel you have to change.

So as long as you can use in most cases and have method to solve specific issues, that should be good.

1 Like

Well, I installed the new v4, and the OpenVPN worked fine. Then I tried using the Travelmate plug-in and now the OpenVPN doesn’t work. I reset the 750 router, and still OpenVPN doesn’t work. Then I tried to uboot and attempted both v3 and v4 .img files, but that failed too. So I can’t even downgrade it back to the stable v3.

OpenVPN Not present Unsupported protocol type.
[Install protocol extensions…]


Something went wrong during updateProbably you have chosen wrong file (too big or too small) or you were trying to update ART on device with unknown FLASH type (and size) which is not allowed. Please, try again or contact with the author of this modification. You can also get more information during update in U-Boot console.

Update: I used the side reset button to reset to factory and that worked better than the GUI reset. Anyway, OpenVPN working again, but still cannot get uboot interface to flash firmware.

1 Like

Same here on the AXT1800 Slate. Updated uboot (that worked), but unable to flash any firmware via uboot. Allbeit gl.inet or vanilla openwrt. It says it’s flashing, the light blinks fast, but nothing actually changes.

Tried multiple browsers on different PC’s with different cables. No idea why it’s not working :man_shrugging:

You used the .img file, right?

Maybe try another power adapter and computer?

I was wondering if 4.2 will be updated to openWRT 22.03.X for the GL-MT3000 ?

Was hoping to have zerotier 1.10 available but unfortunatly, only 1.8.4-2 is available on 21.02

1 Like

Upgraded 4.2.0 snapshot on MT1300 but didn’t see the parental control and zerotier option. Is it not supported on MT1300 model.

By regulation users cannot change country code in the UI.
But when you travel you have to change.

Would you mind sharing how to change the country code on Beryl AX? I suspect this might be the reason why some Wifi-5 devices don’t see the 5GHz network.

1 Like

May not relate to the country code. Do you have further details of this issue?

5GHz setup: security: WPA2+WPA3, mode: 11ac/ax, bw: 80Mhz, ch: Auto, SSID: shown

Visible by: 2018 and 2021 macbook pro, Xiaomi Mi Lite 5G
Not visible by: LG OLED B9 (Wifi 5) and Huawei MediaPad M3 (Wi-Fi 802.11 a/b/g/n/ac)

Have you tried to change channel?
Also try change encryption to WPA2.

Changing the channel solved the issue, however this defeats the point of using automatic channel selection, hence I was suggesting to properly select the country in the first place.

Can you let me know which channle you changed to?
Which country are you in?

I changed to 108 from something over 160 which was auto-selected. I’m in Norway.

I see.

Channel 161 supports 80Mhz
Channle 165 support 20Mhz
They are only limited to 25mWatt output, by regulation.

But in the router, if comes with Europe country code, this channels is disabled completely. This is due to some settings in the wifi driver and designed like this.

Even you can use, 25mWatt should be very weak signal. I am not sure why your current wifi use that.

I tell you why, because the only place where the router is available to purchase in Norway is the, the US site, so I got a router set to US. And regardless where on this globe I buy this, I should be able to change the country (also it’s a travel router, so I am expected to travel to different countries with it).

1 Like

I just posted here on changing the country code for the Wifi Ranges available (note it doesn’t change the devices Country Code as displayed) Slate Plus Title Bar - #4 by SmurfonToast

Perhaps that will help?


1 Like