Firmware V2.21, 2.22 Road warriors, WISP repeater auto connect

Thank you for your quick responce.

It is working now.



I’ve tried v2.22 on my MT300A.

I have factory reset and have downloaded the firmware once via a browser session and also via the GLINET router interface after being prompted that new firmware is available. I’ve upgraded from 2.20

I have the same problems as before -

The Radio AP randomly switches on and off and then remains off - this is when connecting by the Ethernet LAN port. This means I cannot login via wifi even if there are no saved stations in the repeater connection section.

Internal SDCARD is not found or discoverable.

I have tried rebooting and powering off the router a number of times with no success.

If I flash back to 2.20 then everything works again. I’d rather use the latest firmware as it is a pain to have to install the scripts and reset each time a repeater station is unavailable in WISP mode.

Would it be possible for someone else to see if 2.22 works in their MT300A or hopefully tell me what I’m doing wrong ?


Thanks !

Hi pseudonoise,

I’ve also got a MT300A. I did the update to 2.22 and encountered similar problems.

I went back to 2.20 after trying 2.22 so many times.




Just tried out the 2.22 version on my MT300N, I immediatly saw an issue with using an OpenVPN connection that had an integrated private key as well as a certificate inside the .ovpn file. When I downgraded back to 2.20 everything worked as expected.

The result was that when 2.22 was installed and I tried using the specified vpn connection, it seems like the connection was hung on:

OpenVpn is Connecting …

Hi alzhao,

Can you test firmware v2.22 on a MT300A as it’s not working.


I have a AR150 with firmware 2.22.
In WISP-mode I have setup 2 connections.
When switching locations the correct connection is not selected nor is WISP-mode automaticly disabled.
After pressing the resetbutton for more than 5 seconds the connection is disabled. After that I can manualy select the correct connection.

@pseudonoise and @Ben, we re-published v2.22 on 17th so please redownload and test. You need to download manually from our website and upgrade if you have the old v2.22 already. Otherwise just upgrade from v2.20 in the UI.

Please clear your config if you have any problems.

1 AP randomly turn on and off: Did you configured repeater before you upgrade? Maybe you can clear your old configs and re-setup. I don’t observe this problem now but we are testing more. Seems this is because the repeater daemon didn’t start.

  1. SD card didn’t recognized: the re-published firmware solved this issue.

@pykV4hDwDZjUsGBKr83L, only a few bugs of openvpn is fixed. Can you reload the config and try again?

@Freek, did you saved your config when you upgrade from old firmware. Seems the daemon is not started because of this. Can you reset the firmware using the reset key (press and hold for 10 seconds until the middle LED flashes very quickly) or UI.

Hi alzhao,

Thank you for getting back to me.

I’ve tried the re-published latest firmware v2.22. that you mentioned both manually and then downgrading to V2.20 then via UI and still no joy.

As soon as try to connect to an SSID the radio AP switches and remains off (red light on the device goes off).

I tried to reset several times and still no luck.

Can I double check with you to completely clear the old config one has to hold the reset button for about 10 sec and that’s it. Just in case I am doing this wrong and that’s why I can’t get it to work.

On v2.20 everything works.

@alzhao: re-installed firmware 2.22 without the old config. All is working very well now.

Only thing I did not test is Tethering with my iPhone, but I don’t think that had anything to do with my problems.

Very happy with my AR-150 now!

I’ve flashed the new 2.22 on my MiFi V2.1 and the WISP is working great for the original 2.4 GHz AP/Wifi

Having said that I’m now also using an extra 5 GHz USB dongle, but for some reason I am not able to turn the 5 GHz dongle option to on within the GL.iNet web interface. (when turning on it will turn itself off again after several seconds)
Also when scanning the GL.iNet interface is only showing the 2.4 GHz stations.

The strange thing is that the 5 GHz is working fine and even showing turned on when using the OpenWRT interface (under advanced settings)
When doing a scan from the OpenWRT interface the 5 GHz stations are also shown.

Any suggestions on how I can get it turned on (and stay on) within the GL.iNet interface?

@Guest, the UI didn’t test for a separate 5G device. Is its name radio1?

When scanning, it only uses the Internal 2.4G to scan, so only 2.4G stations will found.

It is suggested that you configure this using Luci for this time. We will improve the UI to work with more radios. Thanks

Thank you for the info.
Yes. The 5GHz radio is called radio1

I will use Luci for the 5GHz stations (unfortunately no WISP auto connect when using it this way)

Keep up the good work!

I had been using the 2.21 beta firmware successfully on my AR300M. I switched over to 2.22 and I’m traveling this week and using different hotel’s wifi. I’ve had nothing but problems with 2.22. LONG delays before the WISP access point is seen, disconnects, and slow performance. Fortunately I was able to find a copy of 2.21 beta and went back to that. It’s a much better experience! My WISP access point is seen almost immediately and connection issues I had with the hotel wifi seem to be better.


Performance through my OpenVPN server is a bit slow but it’s manageable. I’m sticking with 2.21 beta over 2.22.

Interesting that v2.21 (testing) works better than v2.22.

The algorithm is further improved and will in v2.23 test again.

anyway to switch to another wifi when the is no internet connection ?


I’m trying to my AR300M v2.22 as a WISP repeater + OpenVPN client. I’ve installed a .ovpn configuration file as provided by (cert + dummy cert + key included inside the .ovpn file).

I fixed the common OpenWRT bug that results in:

write to TUN/TAP : Invalid argument (code=22)

by manually adding the line:

comp-lzo yes

To the ovpn configuration file

Now the router seems to stop at:

OpenVpn is connecting …
PUSH: Received control message: ‘PUSH_REPLY,ping 3,ping-restart 10’
OPTIONS IMPORT: timers and/or timeouts modified
Preserving previous TUN/TAP instance: tun0
Initialization Sequence Completed
Any suggestions?

Along with @pseudonoise and @Ben, 2.22 is still unuseable on my mt300a.

As soon as i attempt to connect to an AP, wifi on the router turns off and doesn’t come back on 'til i reset the router.

Doesnt matter whether i update manually or through the router, or whether i clear configs.

@theP, the current algorithms only checks if there is IP address obtained. But I do think checking if Internet is available is better. At present, you can just disable auto connect to the SSID.

@Packeteer, do you get my email requesting a test of your config?

@Lupercal, Can you tell me what this encryption and protocol of your network? I tried v2.22 on MT300A and it just works as expected. Maybe you can try ssh to the router and check if process “gl_health” is running or not? It is started from rc.local and sometime when you reserve configs this file is not updated. But by doing a factory reset the problem should be solved.