Flint..1st day experience & regrets

Today I received Flint and was excited with same fear that I had with all other Gl-iNet routers I have purchased in past. My fear became a reality and PPPoE did not work as usual. Here is my experience and feedback on Flint particularly and other Gl-iNet models generally (Slate, Mt300n, B1300) which I am sure nobody will care reading or addressing in Gl-iNet support but can help those who are thinking to buy their routers.

1- Since last two years I am writing about PPPoE issue that I’m facing with Gl-iNet routers but support has been very casual about it and no firmware update has ever fixed it. I’m stuck with 3.22 version on B1300 and nobody in the support could figure out what has changed that is causing the issue, if it is fine on their end it means it should be fine for everyone.

2- Still I purchased Flint and SF1200 thinking that they might have fixed it. But the first thing that I came across was NO WiFi. Plugged it into LAN port but still nothing. Had to do a factory reset but still no WiFi and no LAN. Thought about UBoot and tried to see if router is in Uboot but still no access. After resetting the router for two more times somehow GUI showed up after waiting for 35 minutes. Note that I was only able to access the router through LAN and on GUI it asked to initialize WiFi. Have you ever seen any router like that? At least I haven’t.

3- Then the same PPPoE issue which as I mentioned is very old. The only solution provided was unplug and plug in WAN cable after 10 seconds. No success. Even upgrading with the latest firmware released on 13th October didn’t help.

4- SP1200 is in a plastic wrap and still I did not open it but Flint was having no plastic wrap, not sure if it came from the company like that or is opened by customs.

I feel I wasted money on Flint as it can only work for me if used as access point. Living in a country with most advanced Internet services if this router cannot connect then many others might also face the same problem or can face in future with a firmware going out without a QC. My feedback on all other channels will definitely help many others.

1 Like

I’m have 2 brume-w, 2 b-1300, 1 mango and never see problem with pppoe, now i’m waiting 2 Flint’s. Did you check your cable?

Not an issue with the cable as same setup and wire works with B1300 with firmware 3.22. But even if I upgrade B1300 from 3.22 without touching the router it stops working with PPPoE.

Waiting for my Flint to arrive. As per previous posts have had no issues with various gl.inet routers or firmwares with PPOE.

Will test my PPOE here <Australia wonder if that make a difference?> when it arrives and report back.

Best of luck. Can see their support is care free, no response from their side.

What is their return policy, don’t want to waste my money on something that doesn’t work or without support.

I don’t know how to help. Seems your pppoe does not work on any of our product. Although you said it works in old firmware, we don’t know what is the reason.


Hey sorry, for late reply, had to find some time where I could do some swapsies with routers without annoying anyone.

Sadly (?) as per the B1300 thread, I have no problems attaching to PPOE connection here. Running 3.026-1013, IPV6 disabled. Pretty much stock standard.

I know it doesn’t help you but…

It only works with firmware version 3.22


I have upgraded firmware to latest 3.207 on Flint and PPPoE is now working. But I now have WiFi issues which I have mentioned here: Flint WiFi issues - #93 by realjohny