Flint 2 FW 4.5.8 release 4

Here we go the latest FW 4.5.8 release 4


Release note seems the same as previous version:

I can’t see nothing here: GL.iNet download center
And seens like the release note is still the same…

Was a similar experience for me a couple of days back for a different model where my device was able to pull down a newer FW than what was listed on the Download page.

1 Like

The DL center doesn’t reflect this, it’s directly from router upgrade UI. They should upload it to DL center later.

4.5.8 IS BROKEN !!!
At least for me.

I upgraded to 4.5.8 and my router entered an endless reboot loop.
I re-flashed the previous firmware and upgraded to 4.5.8 again and the same problem - the router reboots after startup.

From which version did you upgrade?
Did you choose to keep settings?

I upgraded from 4.5.6 release1.
I chose to keep the settings both times.

Depending on the settings you shouldn’t do that.

1 Like

I just tested the upgrade with unchecked “keep settings” and the problem is still here - endless reboot loop.

I don’t have any plugins installed anyway, I didn’t have any the first two times when I tested with “keep settings” checked.

Firmware v4.5.8 release4 is broken !!

I can’t confirm that this fw is broken, I am using it …

If the update page doesn’t tell you nothing, so you can do in this say.
I updated now from 4.7.4 to this new 4.5.8 and it’s still online by 2h in a row.

Installed 4.5.8 release 4!
For now, first tests, the 2.4GHz wifi seems more stable to me and also the speed on the 2.5G port.
AdGuard and the AdGuard update test seems to be working properly.
As soon as I can, I will also test the Wireguard VPN.

Does fixed uptime running router after 30 days?

This version broke my IPv6 and Tailscale. Tailscale was just stuck to connecting and it wont show / connect to my IPv6. I upgraded with keep settings first and it broke my updated Adguardhome but it was easily been fixed by reinstalling it. However, these two problems persisted even after a reset.

Edit: All working fine now

1 Like

Me too, no issues at all here…

My ISP Router at 1 meter (2.4GHz):

My Flint2 with the firmware 4.5.8 R4 at 1 meter (2.4GHz):

I managed to fix it. I downloaded the firmware from dl.gl-inet.com and installed via UBoot. This time it worked. Very weird.

Anyway - problem solved, v4.5.8 release4 works!

Thanks for the help :slight_smile:

1 Like

Luci GUI is showing txpower as 20dbm on the 5ghz band (should be 23 dbm for my country - UK), and does not allow a higher setting.

Setting to any other regulatory region (ie. DE) displays the same.

Did you try to leave it on driver default?
In my case (US regolatory) it has 24 dBm with driver default setting.
Anyway US should be 30 dBm and is not working anymore (on 4.5.4 I was able to set 30 dBm)

Is this 4.5.8 based on OpenWRT 21?
They didn’t mention anything on the release note (well I kinda know because I followed after 4.5.7 rekt’d my router so i had to factory reset because it downgrades openwrt)