Flint 2 (GL-MT6000 ) - bug reports - collective thread

I would think wireless config was invalid for the driver.

Between 4.5.6 and 4.5.7 a whole different driver is used, this means the wireless devices have been changed in the wireless config.

Though if you want a clean wireless config without resetting, you can get it from /rom/etc/config/wireless if you still have a backup you can update the devices, be aware that alot of wifi features other than the most basic ones probably are unsupported, luci also doesn’t work fully with wireless settings.

1 Like

Problem is when i updated v4.5.6 → v4.5.7 keeping the old settings and tried also resetting. After update router was working but after i did first restart /etc/wireless folder got deleted.

The same thing happened with and without reset after upodate.



Now you have the option to change the WiFi region.

thanks!!! @alex_zheng

Edit: For those who have MT3000, a new beta version has also come out, with some corrections and the updated tailscale.



Now let’s wait for the WiFi power regulator to start crying here


@alex_zheng what are the changes from version 4.5.7 release5 to release6? In the changelog on the download page there was no change in the description. My question is whether only the option to select the country was added to Luci or whether there were other changes.

Also, could we talk about the advancements in resolving the 2.4 GHz driver issue? Has the cause of the problem already been found?

This configuration always comes back and in this version it came back, polluting the log with a lot of information and has already been corrected in another post.

Below is a print and link to the correction.

uci set system.@system[0].cronloglevel="10"
uci commit system
uci show system
/etc/init.d/gl_timer restart

detail that the last command causes gl_timer to restart, it didn’t work through ssh, I had to go to Luci and restart the process located in System/Startup

@alzhao @alex_zheng @JerryZhao @hansome

Edit: The same error I reported a few posts ago continues to occur.

“DHCP packet received on eth1 which has no address”

and also the fix was not placed in the versions after I posted the fix.

echo "except-interface=eth1" >> /etc/dnsmasq.conf
service dnsmasq restart
1 Like

I can’t wait to have that upgraded Tailscale version for the Flint 2

No need to wait: How-To: Update Tailscale on ARM64/ARMv7 (f.e. Flint2/AXT1800)

1 Like

Yeah but I had an issue after upgrading it, I think we already talked about it, so I hope on that new firmware version it works fine

So ive sent @alex_zheng my logs as requested.

4.5.7 R6 has fixed the issue where I wasnt able to set the country code in Luci

But the same issue where I set channel 128 / 160hz 5ghz is still not working, this issue applies to all of the 100+ channels on this firmware, if I force set channel 64 DFS that works, or channel 60, that works too, but 100, 102, 108, 116, 120, 124, and 128 all scan for about 5 mins or so and then default to channel 40, but it works fine on 4.5.6.

1 Like

Some bug for you guys and inner test is fixed.

No process on the 2.4G issue, We need to focus on close source wifi driver version this month.

1 Like

I’m asking our collegue for the version plan, will have a feedback quickly

Got it. It seems hree bug that didn’t compile in the R6 version. We will check it.

I did the test here and both the wifi region and the channel work normally

But changing the WiFi region is changing something?

Go to LuCi → Top menu Network → Wireless → Edit your 5GHz network unticking the option “Force 40MHz mode”

Yes, it limits the power of the WiFi and the availability of channels…

I mean, it’s really changing?
Check with the WiFi Analyser (or whatever similar app)

in any app it is limited to 19dbm for 5ghz and 17 for 2.4ghz regardless of what you change. As the dev already commented, it is a bug that has yet to be fixed. If you have any doubts, update there and do your test, put it in Europe and check if it limits the power.

So, it’s changing nothing?