Flint 2 (GL-MT6000 ) - bug reports - collective thread

I have updated to 4.5.8 beta, for now I have only noticed that my Redmi Note 11 no longer wants to connect to 5Ghz despite being a few centimeters from the router.

Try to forget the network on the Redmi and connect again - this can help if it’s some WPA-problem.

1 Like

I tried, it doesn’t work

Part of the issue is that the chipset manufacturers think there is some secret sauce in their driver code. Most probably, there is not as WIFI is a public standard. MediaTek is becoming more like Broadcom.

Ok it seems that the only way to connect the smartphone to 5Ghz was to deactivate 2.4Ghz on the router, the Redmi at this point connects to 5Ghz and then reactivates 2.4Ghz, at which point it remains connected to 5Ghz.
With the other devices I have no problems and they connect to 5Ghz normally, with the 4.5.7 and 4.5.6 firmware I didn’t have this problem, however, is it a problem with the smartphone or with the new firmware? maybe.
Edit: Same problem with old Redmi Note 8

1 Like

hmm i seemingly see errors on my ra0(2.4ghz) interface for 4.5.8.

ra0       Link encap:Ethernet  HWaddr <snip> 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15295 errors:2212 dropped:0 overruns:0 frame:0
          TX packets:9511 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7157732 (6.8 MiB)  TX bytes:3307062 (3.1 MiB)
          Interrupt:6 

RX packets:15295 errors:2212 dropped:0 overruns:0 frame:0

on this phy, my zigbee network is running with alot of multicast broadcasting.

on my upstream router (connected on the lan1/2.5gbE):

eth0      Link encap:Ethernet  HWaddr <snip> 
          inet6 addr: fe80::9683:c4ff:fea0:37fc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1504  Metric:1
          RX packets:144374662 errors:6 dropped:2205 overruns:0 frame:0
          TX packets:300058486 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:24183469922 (22.5 GiB)  TX bytes:328318300087 (305.7 GiB)
          Interrupt:119 

I have did some overhaul to my network in response of this, because i’ve been told to not mix bridge vlan devices with other bridges, this may could cause very unexpected strange symptoms very deep inside the kernel and there is not known what it could be possible break.

so it looks now like this on the upstream side, this will make 802.1q and vxlan work with each other:

but the errors still seem to be there, I suspect multicast to be broken?

I can replicate this when i start my reddit app on my phone connected to rax0(5ghz) phy and scroll as soon when that happens the connection failure appears on all of my devices like im able to create a DoS through the app :expressionless:

some confirminations can be nice :slight_smile:

-edit-

I fixed the reddit issue but the ifconfig results remain the same on the mediatek sdk firmware 4.5.8.

I had this problem when using Flint 2 v.4.5.7 as a dumb AP with my ISP gateway as router (which never gave me trouble). I am back to using R7800 temporarily but will load in 4.5.8 and do some testing on my Flint 2. Reddit was especially triggering for these disconnects in my case as well.

1 Like

Are you using the same SSID for both bands? You could try using 2 different SSIDs.

Also just looking 4.5.4 / OpenWRT 23.x upgrades. I got Flint 2 far cheaper than other options for a 2.5Gbps router. I get amazing 5GHz wifi range and decent speed. I simply got a $0 Airport Extreme to dumbAP the 2.4GHz wifi. The rest of my wifi extensions and 90% of my devices are over ethernet anyway. Feel bad for others. But for people like me this whole controversy is utterly meaningless.

1 Like

I just tried upgrading from 4.5.6 to 4.5.8 and my phone refused to connect to the WiFi on 5GHz. I didn’t try 2.4GHz.

I’m going back to 4.5.6, should never have bothered.

2 Likes

What model is your mobile phone?
And please export log.

When will the next build based on 4.5.6 come out? Or can GL provide the GUI to us so we could build our own OpenWRT builds and add on the GL GUI?

I was testing v4.5.8 and found two relevant bugs:

  • Changing the country code has no effect on the maximum signal transmission power. I tested countries like Brazil, China and Germany, all are limited to 20 dBm

Glinet v4.5.8

  • Packet loss in v4.5.8 on the 2.4GHz band is worse when compared to the latest OpenWRT (r25676-2feedab805).
    v4.5.8:

OpenWRT (r25676-2feedab805)

Tested in Motorola Edge 30 Neo in 40 MHz frequency

1 Like

Yeah, I don’t see that happening :thinking:

@skylab I think i figured out the issue for reddit, it seems to be on my side.

I was using the package banip and figured it was blocking reddit.map.fastly.net i simply used the dig command like: dig www.reddit.com and dig @8.8.8.8 www.reddit.com and it was showing different results, it got me scared a little in case of dns cache poisoning but both results pointed to fastly I then realized this domain was blocked through banip, and strangely enough somehow fastly managed to crash my network due that block i guess they use it as some sort of blockhole address or something, adding this to my allowence list fixed the problem.

^ though the issue i had with RX/TX errors is still present on the mediatek sdk firmware.

1 Like

OnePlus 9RT, sorry I don’t have the log now and I’ve already gone back to 4.5.6.

I installed the 4.5.8 beta firmware, but I notice that the 2.5G LAN problem remains. Despite having everything at 2.5G the maximum speed it reaches is just under 1G.
The internet line is an FTTH where with WiFi I reach 2G without problems and doing tests from multiple devices at the same time I reach 3G without problems, so it is not a line problem.
Also checking the various ETH ports they are all set correctly to 2.5G and with the initial firmwares I never had this problem (probably born with 4.5.6)

In addition, I still noticed an instability to the 2.4G WiFi not working properly with very low download speeds

The problem of instability on 2.4 Ghz WiFi remains with 4.5.8 beta, unstable ping and packet losses.
I also noticed that if I activate SSH I find things like this in the log:
authpriv.info dropbear[11335]: Child connection from xxx.xxx.xxx.xxx:52758
authpriv.warn dropbear[11335]: Login attempt for nonexistent user
authpriv.info dropbear[11335]: Exit before auth from xxx.xxx.xxx.xxx:52758: Exited normally
xxx.xxx.xxx.xxx is not my IP from another country, is SSH open to the outside by chance? it shouldn’t be. in any case I always deactivate it after using it.

1 Like

Where did you activate it? Luci or the Gl-inet interface?

Isnt SSH port for connection already open from the box / by default?