Flint 2 won't connect to the modem

Hi I am trying to set up my new flint 2 router. I connected my modem to the WAN port and in the admin it just keeps saying Connecting, but there is no internet connection. I disconnected and started using my old router it everything works fine again. Both the modem and old router are my own and not provided by my ISP

Have you tried it via luci on the flint 2 :smile:?

I readed on some topics there might be a issue getting pppoe to work with ipv6 on.

I am using DHCP to connect. I also update the firmware to 4.5.4 and still no luck.

Could you please follow this thread to provide some more technical information?

Thanks in advance!

Here you go
You should provide the following information in your forum post:

  • Which router (which model?) are you using? - GL-MT6000
  • Which firmware version is in use? - 4.5.4
  • How is your router connected to the Internet? - By cable via a modem (standard Arris Surfboard) owned by me
  • Which DNS server do you use? - local one
  • Do you use DHCP or static IP addresses? - DHCP

Does your Flint get a DHCP address?
Can you ping and it will respond?
Can you nslookup gl-inet.com and there is a response?

It doesn’t get a DHCP address. It just “Connecting” but no IP address assigned.
When I try to ping i get Destination net unreachable.
What am I doing wrong? This should just work right? ISP → modem → router

Do you usually get a address by using DHCP?
How was it with the old one?

Are you sure it is modem? Or could be ONT box?

Yes its a pretty standard modem Arris surfboard sb6183

Yes as soon as i switch back to my old router, I get a IP address using DHCP and everything works fine. Old router is a very basic TP link router.

Are there any options inside the cable modem? Maybe there is a DHCP reservation?
Was the TP link one from your ISP or did you buy it by yourself?

How do I check for DHCP reservation on my modem? The router is mine and not provided by the ISP

Should I try to set a static IP address?

What DHCP address will get the old one?
You could try to copy it.

The old router has a range from -, the DNS was I can’t copy that the flint 2 needs a specific IP and a net mask.

That’s not the address the router got. It‘s the DHCP range.

Worth a try.

But for me it sounds like the old router was known by the ISP so they enabled DHCP for it.

@admon Where and which DHCP server is located? in the cloud? ISP? :thinking: :thinking:
@freshgouda Could you show us a screenshot old TP link router page where the is modem connected? by DHCP or PPPoE?
hide or blur your real IP and IP gateway

It is DHCP., It says connection type “Dynamic IP” .