Flint AX1800 can't revert 3.X firmware, switch errors on 4.X

Flint AX1800 can’t revert 3.X firmware, switch errors on 4.X.
Uboot is on the latest version, i can uboot any 4.X version, but, if i uboot any 3.X version it doesn’t work.
4.X version is working but very strangely, keeps losing LAN and WAN randomly, when LAN or WAN is lost can’t login to, only logs again if i restart

Are you keeping settings somehow in 4.x firmware upgrade or reloading settings config file from 3.x? Uboot uses the .IMG file not .TAR. Did you maybe get the AXT1800 firmware? 3.x downgrade I think takes longer.

:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

I’m not keep settings, by the way the default settings always worked just fine in my setup, the firmware available on 3.X are all .img, and i’m getting the right firmware for the right model: Flint AX1800.
The device worked just fine in 3.X.

I’ve waited one time more than 40 minutes for the firmware goes up and nothing.

Should take maybe 10 min max.
Should have one wired connection to router nothing else connected.
Try a private browser window.
You mentioned Uboot was updated, are you possible loading .IMG file in the Uboot update screen( and not he uboot firmware(

Only other thing is resetting with serial UART

I tried with normal and inprivate window on two different browser, yes i’m loading the .img file on the correct path: with only one cable plugged on port lan1, tried on lan2, lan3 and lan4

I am out of ideas. Try messaging @alzhao(GL.iNET staff) or @solidus1983. solidus1983 does a lot of custom img. files might have something to get it back to stock

Thanks folks, tonight i upload all the screenshots of the errors and contact the guys

Folks, this is the screenshots i’ve made, on the Luci - Switch interface it always appears port 1 connected even if i don’t have any cables on any port.

Thats how its supposed to be what does the system log and kernel log show?

can i send you the logs?