Flint beta firmware 4.0.0 change log?

What is in the newest 4.0.0 beta build for the Flint?

I see there are now 2 files, one for uboot and one for the update from Admin Panel?
This firmware appears to be 20% larger in file size?

What are the changes, is there a change log?

Is this already stable enough to use, what are the benefits of using this 4.0.0 beta firmware now?

It’s stable enough to use the 4.0 firmware.

When you want to switch firmware from 3.x to 4.0 beta, you need to download the Uboot one to upgrade.



How do you get the Flint into Uboot mode to upload?
I tried pressing the “synch” button while booting with a LAN cable plugged in (LAN nearest the WAN), it just booted normally into th current firmware?

According to debricking article, should flash 3 times then LED goes white.


You need to remove the power, hold down the reset button with a pin or toothpick and insert the power plug then the correct flashing will occur and you should be in uboot mode.

1 Like

Lol, Stupi me! Use the reset buttton not the synch button. Did not spot it, as I assumed the “button” was the button to use.

What does the synch button actually do.


Sync button does nothing. Was going to be for mesh setup but functionality was dropped at release.

LOL, you press the WRONG button :laughing:

The AX1800 mesh support discussion thread: (that’s where I found the sync button was mentioned for the first time)

Flint GL-AX1800 Mesh Setup - GL.iNet Routers Technical Support - GL.iNet (gl-inet.com)

Where is the change log?

and speaking of uboot,… I was hoping for some sort of uboot backup (firmware+user config) before trying out 4.xx :: so if i don’t like it, i execute a file and previous firmware and config that worked, restored instantly. If such feature does not exist, IT Should!

Well, as for the previous firmware, I believe if you want to go from fw 4 to 3 you have to use the stable firmware 3 but upload it via uboot, not via webinterface.

As for config backup, I think it is only via OpenWRT luci, but not recommended I think.

It’s basically there. You need the V3 image, and make a backup in LuCi (you can select what to save).

Flash firmware V3, flash backup in LuCi, done🤷‍♂️

OpenWRT 21’s changelog say " TLS and HTTPS support included by default" among other things mentioned here so does it mean that Flint can be accessed via HTTPS? (along with others like Adguard etc?)

Can anyone who installed version4 test this? I’m anxiously waiting for adguard to filter https connections through above change :slight_smile:

Edit: speaking of backups,… I HATE LuCi :rage: after saving things in LuCi, I was horrified to see many of other settings messed up in standard UI (which only got fixed after uBoot hard reset)

When people here say,… “you can always use LuCi and get that done” I read is double meaning “you can always hit a hammer :hammer: on your Flint” :face_with_spiral_eyes:

Kernel 4.4.60 (OpenWrt 21.02-SNAPSHOT, r16273+113-378769b555) and still IPv6 not working. At least I can now use material-theme for LuCI. With all these can’t resolve address errors the flint still isn’t ready to be the primary router connected to the fibre modem. I still prefer old but well supported WiFi 5 routers.

I could not download the gre protocol for Flint.
I sort of expected this as the feed is opewrt snapshot, where as the AXT-1800 has some gl-inet respositories. I suspect the focus is on get Slate AXT 4 out the door and then flint.

From my quick test for normal routing it seems OK, anything too fancy and you may have package dependency problems. Not ready yet, but I will be loving the flint when version 4 becomes stable!

Until then AXT-1800 seems the best GL.inet router.