Flint firmware 4.1.0 release5 is out


~~ https://fw.gl-inet.com/firmware/snapshots/20221031_4.1.0_release5/ax1800/openwrt-ax1800-4.1.0-1105-1667630218.tar ~~


~~ https://fw.gl-inet.com/firmware/snapshots/202210``31_4.1.0_release5/ax1800/openwrt-~~ax1800-4.1.0-1105-1667630218.img ~~

~~GL.iNet firmware download:https://dl.gl-inet.com/ ~~

Release Notes:

V4.1.0 - Nov 5,2022


Optimize the structure of the side feature menu bar

Fix the occasional error message


Add VLAN ID setting entry in PPPoE mode~~

Fix unplugging the cable in Static mode will reset the static IP Settings

Add support for EM160R/EM060k/EM120K/RM520N modems


Fix Nginx memory leak


Fix issue to ensure that deleting saved Wi-Fis does not cause crash

Fix for repeating Wi-Fi with WPA2 EAP will fail

Add error message that repeating fails due to MAC Clone


Fix occasional non-broadcast of Guest Wi-Fi after router reboot

Fix incorrect display of Guest Wi-Fi in Bridge/AP/Extender/WDS mode

Fix memory leaks

Fix Guest Wi-Fi will fail when repeating


Add device type and name modification feature

Add device list sorting feature

Optimize the speed display to show the average speed of the last 3 minutes


Add Tor feature

Optimize the display of the proxy mode switch button to make it more eye-catching

Added a wizard to setup VPN Client

Add the start VPN button to the list of configuration files on the VPN Client page

Add the restriction rule to prevent the upload of OpenVPN configuration files with different encryption methods to the same group

Fix uploading larger zip files that would fail

Add a limit on the number of configuration files within an upload zip file, not more than 1000 per zip file

Fix the failure to add the same routing rule as the deleted one

Add error message for failure to decompress uploaded files


Fix multiple MQTT processes appearing

Fix router cannot refresh the binding information after GoodCloud is bound

Fix RTTY cannot connect

Network Storage

Add quick setup share feature

Fix the WAN interface not getting the address due to network storage

Add support for exFAT.


Add Multi-WAN feature

Add IGMP Snooping feature

Fix DDNS not working in Bridge/AP/Extender/WDS mode

Fix the Extender mode does not work when Override DNS Settings for All Clients is enabled.

Fix WDS mode not working when WAN port is used as LAN port

Fix the WAN/LAN mode of WAN port can not be switched in MAC Clone status

Fix Wi-Fi exception after modifying the LAN IP

Fix for IPv6 settings being lost when upgrading firmware with kept settings


Add Overview feature

Add Scheduled Tasks feature

Add reminder dialog for new version upgrade

Fix web logout exception after synchronization timezone

:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

1 Like

was there something wrong with release 4, why has it been superseeded this quickly?

The release note seems to be the same as far as I can tell. Their is a new CVE report for cross site scripting in openWRT:

Zerotier can’t be installed again…
Collected errors:

  • pkg_hash_check_unresolved: cannot find dependency libstdcpp6 for zerotier
  • pkg_hash_fetch_best_installation_candidate: Packages for zerotier found, but incompatible with the architectures configured
  • opkg_install_cmd: Cannot install package zerotier.

Required dependency package “libstdcpp6” is not available in any repository.

1 Like

Random MAC address feature doesn’t work properly.
It can change MAC address only once.
So I have to move to another column and then come back to get more MAC addresses randomly.
It’s a small bug though.

my isp uses vlan id 0 and no username/ password. trying to setup pppoe but it doesn’t let me put 0 as vlan id or leave empty user/pass fields…

Hmm someone tested wireguard server here?

Im not sure if I need to reset config, but I cannot communicate with the server, the logs say that wgserver link is not ready.

I upgraded from beta3 to 5 keeping the configuration.

Think you might need to reset or remake only way I found when I was having issues with a achieved config file I used. I would update without saving packages or settings then load the config achieve. Not sure what caused it but after release3 firewall zones and Ipv6 started doing weird things like trying to resolve DNS when the VPN only allowed ipv4.

I think its the switch from IPtables to NFtables.

1 Like

vlan id 0 means no need vlan. So just leave it blank.

For pppoe usename and password, can you input random?

No idea why it is blank as well.

It is PPPoE or DHCP?

is PPPoE. it doesn’t work with random. neither with vlan id 911 (alternate to vlan id 0). this is not a big issue as i can use their router in bridge mode…

Maybe you can use Luci to config. You don’t need username and password in luci for PPPoE.

We are removing this restriction on our UI as well.

Hi all,
I am a new user to GL-iNet products and OpenWRT. I have just bought the Flint and installed the 4.1.0 R5 beta. Most things to me seem to be running fine for me, however I cannot get Wireguard to start? I click on the generate config which returns a success, but it does not populate the Dashboard. Tried with OpenVPN which seems to work as expected.
Thanks, in advanced.

Can you post screenshots?

This is the Dashboard view.

The wireguard server screen should have changed to this when you clicked Generate Configuration.

Did this window or just success popup?

Try a private browser window and clear your browser cache.

My flint is running 4.1.0 release5 and is not having this issue.

alzhao How does someone delete a wireguard server, cannot find a delete configuration in GL.iNet Admin UI.
:gl_emoji_dizzy:I do not work for and I am not directly associated with

Thanks, I have already tried clearing the cache, private browser and another browser but no luck.
The success box is all that pops up, it’s very quick and doesn’t appear to be doing anything else.
FYI I have used Edge and Chrome in both normal and incognito mode.

It worked fine before updating the beta.


Update plugins maybe?
Have you restarted the router and still get the same result?
Did you retain settings and packages when you upgraded?

This is a Beta so there are going to be some issues. I can’t reproduce the problem on mine so It might be the install or a missing package.

No plugin updates avail.
Restarted router a few times, same result.
I retained the settings during the update.
Can I ask what plugins you have installed for Wireguard on your setup?

It is more than possible that I have done something wrong. Loving the beta compared to the old one.

I just have standard GL.iNet plugins but I have added a some stuff in LuCI such as SQM, Netdata, collectd. LuCI does say that a

It might be the retained settings did not transfer correctly.

If possible I would do a fresh install of the Firmware 4.1.0 release5 do not retain settings and set everything back up manually. Once that is done you can make a config file in LuCI of everything and use that between upgrades

1 Like

sure. it works from Luci, this is the way i made is working but it would be nice to be able to do it from the custom/default webgui. Luci is not for everybody…