Flint firmware 4.1.0 release5 is out

Hi, WireGuard is now working again.

Reverted the beta firmware and did a clean install without transferring any settings. Worked straight away after a reboot.

Could I ask if it’s possible, in AdGuard home, to view the clients in query view rather than just the one local router address??

Thanks for all the help.

Can you try this method GL-MV1000 with AdGuard all clients show as localhost - #31 by morcheba


You also need to REORDER the Rule to the top or appropriate order in chain by dragging it.

1 Like

Thanks, that has done the trick. All devices now showing rather than the one local interface.

Don’t find a place for feature request.

A second wired port for wan/multiwan would be nice. (have a docis and vdsl line).

I think i can do it over luci and mwan3 but over the gl-inet interface would be nice.

1 Like

At the top… [List of current feature requests 2022]
Multiple people have mentioned that and gotten no response…But go ahead and put in a request there.


Is it possible to add the option of IPoE with VLAN id (802.1q option) along with PPPoE for WAN interface? i know it can be done via LUCI but it will be nice to have in the default webgui as many ISPs in UK are using IPoE lately and basic DHCP will not establish internet connection without the possibility of adding VLAN Id…

@alzhao btw, when 4.1.0 will be officially released as stable?

I have a question to the community regarding the GL AXT 1800 4.1.0 release. I am currently running the 4.0.3 with the latest AdguardHome release. This works without any trouble. I fowarded WAN port 53 to the internal AdguardHome 3053 port, so DNS requests are answered in my network by tAdguardHome. When I upgrade to the latest firmware version 4.1.0 AdguardHome stops working for me. Port forwarding is the same. Has something changed with firmware version 4.1.0?

should not change anything.

Do you mean adguard home is not working or the dns forward is not working?

I had a few issues when upgrading to 4.1.0 and keeping my current settings. A clean install without saving any configs seemed to do the trick for me.
Not sure if that is possible in your situation?

“Failed to update repository list, please check your network and try again.”
Everything is fine with the internet! Problems with repositories again?

I have had the same problem the past 48hours, worked previosly.

!!!DON’T DO!!! Will update If my vpn is off and/or allow non-vpn traffic.
!!!Do not do !!!
Latest Repository broke my LAN DNS resolving some how, funny enough my phone was on the guest network and worked fine. Anything connected to the LAN will not resolve DNS. I can ping but can’t ping www.google.com or google.com. Trying to figure out what happened.

Are you using a VPN? Does it only us IPv4?

It seems the repository config really wants to use IPv6.

Fixed it the the VPN Policy route mode was set to auto detected and I switched it to client,

Libstdcpp6 is there now

This is great news! Would… If…
“Failed to update repository list, please check your network and try again.”

I had a problem I posted early and then rectified.

Are you using a VPN that only uses Ipv4?

@alzhao, the routing isn’t working. I do the routing via Lucie. WAN port 53 to LAN port3053.
I already started from scratch, and installed the latest release, but no luck with the routing problem.
In version 4.0.3 I don’t run into this problem.

should be Source zone LAN port 53 to Internal Zone LAN port 3053

But the AXT-1800 isn’t the main router, that’s a Fritz!Box behind the WAN interface. The AXT-1800 only provides the AdguardHome DNS service via port 3053 which is by default not open to the WAN side, where others LAN devices are connected. And it worked with 4.0.3, but it doesn’t with the new firmware.
That’s my config with firmware 4.0.3 which is working:

Is it the first rule?

Also I think you need to do something with firewall Zones.
I Found this somewhat useful and it explains the problem. Basically its not a clear communication of iptables to nftables from FW3 to FW4. I have avoided this because I installed SQM

For the Backend “I will do it myself” people: