Flint memory leak ?

After almost 1 month uptime,Flint memory usage grows every day from around 80% to now 96% and keep increasing. :thinking: (Only WiFi serving and DoT DNS configured, nothing special running)

Have you checked the usage in luci or from the cli? It can identify what is using all that memory, my guess is it is just cacheing.

Well, after memory usage reach to 98% or 99% or something, it reboot itself, sigh ~

Did you use adguardhome? When this happen, can you ssh to the router and check using ps?

No AdGuard Home enabled, only NextDNS DoT configured and pure Wi-Fi serving and WireGuard server running.

The ps command listing output I can’t see any specified process take a lot of memory usage, most of them the maximum only take around 1.2% usage and the total amount of the processes take seems not match that much memory as shown in the App statistics.

Understood. Will investigate the same scenario.

I have the same problem, my network after i connect to ax1800 reboots frequently, after i check it before reboot the memory total used by the process is 98%, after reboot the memory going back to 88%.

Please fix this memory leak problem

after reboot, my Flint memory is around 73% then it will increase around 1% every day…

My memory usage after reboot is 66%. What server did you turn on?

I only use adguardhome, i don’t install any addon.

Today i disconnected my flint because memory leak and reboot problem and waiting for new firmware.

Hi cafebug:

Could you help me check some information?

Login via ssh ,then exec the following:
pid=$(pidof AdGuardHome);cat /proc/$pid/status

Then send me the screenshot.

Thanks!

actually, I never have AdGuardHome turned on, so your command doesn’t work. :slight_smile:

Same problem for me. Memory at 96% but with adguard on

Yes, the memory leaking problem is pita.

Can you ssh to the router and use the following command to see if the RAM will drop?

echo '3' > /proc/sys/vm/drop_caches

Pls let me know the result.

Let me try it and report back …

Before & After Command: (It works ) (78% —> 62% ) :grinning:

image

OK. Thanks very much.

Seems we identified the problem. Pls wait for the new firmware. Compiling asap.

3 Likes

Pls try 3.207 from https://dl.gl-inet.com/firmware/ax1800/testing/