Flint won't connect to the internet after a power outage

I recently bought a new Flint router. It’s flashed with firmware 4.1 release 6 out of the box.
I configured VPN client on it - no issue
I notice that after a power outage, it won’t reconnect to the internet. I have to reboot it to connect to the internet.

It seems that when the Flint restarts, it needs to see the internet working on the modem.
However after a power outage, the modem takes more time to establish the internet than the Flint. The Flint is ready before the modem. So the Flint decides there is no internet and it doesn’t try to reconnect. And I have to reboot it by myself to connect to the internet.

My network:
Cable Modem - router 1 - Flint connected to router 1 as router mode in wan port.

Any ideas how I can fix this issue or workaround?


It seems a uboot problem, that can be solved updating it.
This topic explains it better:

Could also be how the Multi-WAN is setup conflicting with the VPN killswitch.

4.2.0 is just released today. Can you pls try?

Is the vpn openvpn or wireguard? Can you give the log?

@alzhao 4.2 Issued in the stable or beta?
I can’t find any new firmware released today

I think alzhao might be referring to this.
This build changes daily
Date Compiled: 2023-03-14 18:46:46 (UTC-04:00)

SHA256: 49584066b47373d9c303ac90e17643bb527268bb277f887df2001d8b87cf433b
It is a snapshot Firmware build
The beta build is from 3-9-2023 (Month-day-year)

I mean this one GL.iNet download center

Try without keep settings to avoid bugs during upgrade.

This happens to me every single time I restart the Flint or if there’s a power outage. Even with the newest firmware (4.2.3) I still experience this problem.

I have tried fiddling with the DHCP settings being received from the upper device (Zhone Fiber Router) and some of the other settings on the Flint but it seems the only way to fix the issue is to completely reset the firmware every time the Flint loses power.

Definately it should not need to reset the firmware.

Does the happen when the Zhone Fiber Router lost power?

Can you try this:

  1. Only power cycle the Flint router to see if this happens
  2. Power cycle the Zhone Fiber Router to see if this happens
  3. Power cycle both router to see if this happens
  4. When this happens, login the Flint router and export the log

This behavior is happening on my brume2 which is connected to a cable modem.

When I reboot the brume2 it will not get dhcp from cable modem unless I unplug the cable modem.

My ASUS and eero routers never had these issues rebooting and obtaining an IP from my ISP cable modem through DHCP after reboots/upgrades.

This is definitely an issue with glinet device firmware.

Do you reboot the modem and Brume 2 at the same time? Or just the Brume 2?

Confirm same problem on mt2500

Just the brume2. Also happens with my flint.

Why should I have to reboot my cable modem or even better question is how would I even do that remotely… as I’m not physically around the router to manage it all the time.

My previous routers had absolutely no issues rebooting without me rebooting the cable modem to obtain an IP through DCHP. Only these glinet products have this issue for me. There must be some way to correct how these devices are negotiating a WAN address and have them time out and try again after a short amount of time if they fail until an address is assigned.

As I stated there has never been a need to restart my cable modem to get a DHCP address on any of the routers I’ve used prior on this same cable modem.

You issue is different from the post auth.

He is saying that he need to reboot Flint to get Internet. While you are saying to reboot modem.

I need some more info to tell the reason. When there is a problem, does Flint get any IP, detect cable connection on the WAN or nothing? Is there any log?

Can you tell me what kind of cable does the ISP provide you? Coaxial Cable?

For old cable modems, generally modem need to be boot first, in order to avoid problems. But I don’t have such network here anymore. So difficult to tell.

Mt2500 connects to a main router (rt-ac68u)

Main router establishes connection using pppoe

Isp is fibre+modem then rj45 to main router

Main router starts up much slower than mt2500 so mt2500 has no internet when completes bootup

When main router finally has wan connection, the mt2500 doesnt refresh and stays without internet connection

So MT2500 just tell you no cable, no IP or private IP?

I have no info on that just no internet when I connect as wireless client, I’ll check the next time it happens

There’s an option to scan and reconnect when it drops the signal. Make sure it is enabled. Sometimes it won’t connect because of a timeout. The signal didn’t return in so many tries so it drops it completely to prevent pointless traffic. Don’t quote me but you should be able to change that in luci…

I have mine connected to the 5g signal and if that drops out it switches to the 2.4g signal. If they both drop out then I know there’s a bigger issue at hand, like a wan disconnect or main router hanged itself.