GL-A1300 - How to disable DFS validation?

Hi, I just got a GL-A1300 (Slate Plus) to travel with in Europe,
and I was trying it out at home and was having issues with it connecting to my home wifi.

Seems my 5GHz wifi AP is on CH132, which seems to be a DFS channel.
Now I’m in Canada and I’m seeing a bunch of APs on CH52-64, and a couple on CH132-144…

And it seems that this is my problem, since I saw this in my system logs
[…]gl-sdk4-repeater/usr/sbin/repeater:701) skip bss with dfs channel: :BSSID

I’ve tried a couple of the solutions of this forum:
DFS Wifi GL.iNet routers - #2 by alzhao GL-AR750 workaround
MT1300 (Beryl), FW 3.201 and DFS Beryl workaround on old fw

but nothing seems to work. I know it’s annoying to get the DFS certification, but why sell it in Canada if I can’t connect it to a DFS network anyway?
Is there a way to disable this validation?


If you are in a country where DFS is needed it is illegal to disable DFS and use DFS-channels. This can lead to huge problems with the authorities.
If you are in Canada, you have to use the country-code of Canada. If your router can not make DFS, than you can not use the DFS-channels.
Here you can find more information about the usable channels: List of WLAN channels - Wikipedia

1 Like

Is there a guide to setting the country codes in GL-A1300?
I’ve tinkered with /etc/config/wireless / uci commands to try setting the region, but it seems that the repeater mode is still blocking it.

It’s not that I want to broadcast on DFS channels with the GL-A1300, just to connect it to a DFS channel to be able to use as source internet connection.
I’m guessing that the issue is that the GL-A1300 only has two wireless network interfaces (2.4GHz, 5GHz), which might mean that the 5GHz repeater BSSID needs to be on the same as the AP channel.

If I could just connect to a DFS network, but rebroadcast on any other channels, that works for me too.

A stupid workaround I’ve found is to connect my android phone to the GL-A1300, which has no issues connecting to the DFS channel (of course), and have GL-A1300 use that as the internet source, via USB tethering.

Maybe there’s a way to use another usb wifi adapter to achieve the same without too much tinkering with openwrt?