GL-A1300 + USB EP06: network connection problem

I managed to fix USB detection issue with EP06-E with firmware 4.2.1, as described here:

Now I noticed that after a short time that I don’t use the modem (about two, three hours) it disconnects from the internet. As in the photos below. And every time I have to enter the modem manually and click on “abort” and then reconnect manually.

I tried saving a TTL in manual as well but when I click on “manual” it doesn’t save.
I believe that the provider, after a while, sends the user to sleep. Then the connection should be rechecked and the IP released again. How can I solve this problem?
I use the 4G network as my main network.


this is what i get after connection:

root@GL-A1300:~# uqmi -d /dev/cdc-wdm0 --get-current-settings
        "pdp-type": "ipv4",
        "ip-family": "ipv4",
        "mtu": 1500,
        "ipv4": {
                "ip": "",
                "dns1": "",
                "dns2": "",
                "gateway": "",
                "subnet": ""
        "ipv6": {

        "domain-names": {

root@GL-A1300:~# uqmi -d /dev/cdc-wdm0 --wda-get-data-format
root@GL-A1300:~# uqmi -d /dev/cdc-wdm0 --get-data-status

This is what I get when it doesn’t work:

root@GL-A1300:~# uqmi -d /dev/cdc-wdm0 --get-current-settings
"Out of call"
root@GL-A1300:~# uqmi -d /dev/cdc-wdm0 --get-data-status


Also having a XE300-EU modem with the same EP06-E modem, I tested it with the same SIM. I noticed that this router makes a renewal request (release time), while the AC1300 router hangs. Here is the AC1300 system log:

Tue May  2 09:10:02 2023 : luci: accepted login on / for root from
Tue May  2 09:15:33 2023 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 00:XX:XX:XX:XX:be 0 0
Tue May  2 09:18:35 2023 hostapd: wlan1: STA 00:XX:XX:XX:XX:be IEEE 802.11: authenticated
Tue May  2 09:18:35 2023 hostapd: wlan1: STA 00:XX:XX:XX:XX:be IEEE 802.11: associated (aid 1)
Tue May  2 09:18:35 2023 daemon.notice hostapd: wlan1: STA-OPMODE-SMPS-MODE-CHANGED 00:XX:XX:XX:XX:be off
Tue May  2 09:18:35 2023 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 00:XX:XX:XX:XX:be 0 0
Tue May  2 09:18:35 2023 hostapd: wlan1: STA 00:XX:XX:XX:XX:be RADIUS: starting accounting session D779893AE0550CF7
Tue May  2 09:18:35 2023 hostapd: wlan1: STA 00:XX:XX:XX:XX:be WPA: pairwise key handshake completed (RSN)
Tue May  2 09:18:35 2023 daemon.notice hostapd: wlan1: EAPOL-4WAY-HS-COMPLETED 00:XX:XX:XX:XX:be
Tue May  2 09:18:35 2023 dnsmasq-dhcp[5483]: DHCPREQUEST(br-lan) 00:XX:XX:XX:XX:be
Tue May  2 09:18:35 2023 dnsmasq-dhcp[5483]: DHCPACK(br-lan) 00:XX:XX:XX:XX:be DESKTOP-2USQV6D
Tue May  2 09:19:25 2023 daemon.notice netifd: modem_1_1_4 (4333): udhcpc: sending renew to
Tue May  2 09:19:37 2023 user.notice mwan3[4631]: Execute ifdown event on interface modem_1_1 (wwan0)
Tue May  2 09:19:39 2023 user.notice firewall: Reloading firewall due to ifdown of modem_1_1 (wwan0)
Tue May  2 09:19:40 2023 authpriv.notice sudo:     root : PWD=/ ; USER=root ; GROUP=nonevpn ; COMMAND=/usr/lib/ddns/ -- stop
Tue May  2 09:19:41 2023 mwan3track[11785]: Detect ifdown event on interface modem_1_1 (wwan0)
Tue May  2 09:19:46 2023 user.notice mwan3track[11785]: Interface modem_1_1 (wwan0) is offline
Tue May  2 09:20:39 2023 : luci: accepted login on / for root from

I’ve come to the conclusion that by killing the “qmi” process, the system can restart the modem and make it reconnect.
I am requesting assistance in resolving this issue.

root@GL-A1300:~# ps
    1 root      1412 S    /sbin/procd
    2 root         0 SW   [kthreadd]
    3 root         0 IW<  [rcu_gp]
    4 root         0 IW<  [rcu_par_gp]
    6 root         0 IW<  [kworker/0:0H-kb]
    8 root         0 IW<  [mm_percpu_wq]
    9 root         0 SW   [ksoftirqd/0]
   10 root         0 IW   [rcu_sched]
   11 root         0 SW   [migration/0]
   12 root         0 SW   [cpuhp/0]
   13 root         0 SW   [cpuhp/1]
   14 root         0 SW   [migration/1]
   15 root         0 SW   [ksoftirqd/1]
   17 root         0 IW<  [kworker/1:0H-kb]
   18 root         0 SW   [cpuhp/2]
   19 root         0 SW   [migration/2]
   20 root         0 SW   [ksoftirqd/2]
   22 root         0 IW<  [kworker/2:0H-kb]
   23 root         0 SW   [cpuhp/3]
   24 root         0 SW   [migration/3]
   25 root         0 SW   [ksoftirqd/3]
   27 root         0 IW<  [kworker/3:0H-kb]
   28 root         0 IW<  [netns]
   30 root         0 SW   [oom_reaper]
   31 root         0 IW<  [writeback]
   32 root         0 SW   [kcompactd0]
   39 root         0 IW<  [pencrypt_serial]
   40 root         0 IW<  [pdecrypt_serial]
   41 root         0 IW<  [cryptd]
   62 root         0 IW<  [kblockd]
   63 root         0 IW<  [blkcg_punt_bio]
   64 root         0 SW   [watchdogd]
   70 root         0 SW   [kswapd0]
   72 root         0 IW<  [kthrotld]
   73 root         0 SW   [spi0]
   81 root         0 IW   [kworker/3:1-eve]
   92 root         0 IW<  [ipv6_addrconf]
  104 root         0 SW   [ubi_bgt0d]
  106 root         0 IW   [kworker/1:3-eve]
  109 root         0 IW<  [kworker/2:1H-kb]
  110 root         0 IW<  [kworker/1:1H-kb]
  117 root         0 IW<  [kworker/0:1H-kb]
  118 root         0 IW<  [kworker/3:1H-kb]
  123 root         0 SW   [irq/94-keys]
  124 root         0 SW   [irq/95-keys]
  125 root         0 IW<  [uas]
  237 root         0 SW   [ubifs_bgt0_2]
  284 ubus      1048 S    /sbin/ubusd
  320 root       700 S    /sbin/askfirst /usr/libexec/
  563 root       812 S    /sbin/urngd
  643 root         0 IW<  [rpciod]
  644 root         0 IW<  [kworker/u9:0-xp]
  645 root         0 IW<  [xprtiod]
  649 root         0 IW<  [nfsiod]
  671 root         0 IW<  [cfg80211]
  681 root         0 IW<  [ath10k_wq]
  682 root         0 IW<  [ath10k_aux_wq]
  683 root         0 IW<  [ath10k_tx_compl]
 1410 root         0 IW<  [ath10k_wq]
 1411 root         0 IW<  [ath10k_aux_wq]
 1412 root         0 IW<  [ath10k_tx_compl]
 1590 dnsmasq   2676 S    /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf.cfg01411c -k -x /var/run/dnsmasq/
 2064 root       804 S    /usr/bin/fcgiwrap -c 4 -s unix:/var/run/fcgiwrap.socket
 2120 root      3456 S    {gl-ngx-session} /usr/bin/lua /usr/sbin/gl-ngx-session
 2163 root       828 S    /usr/bin/fcgiwrap -c 4 -s unix:/var/run/fcgiwrap.socket
 2164 root       828 S    /usr/bin/fcgiwrap -c 4 -s unix:/var/run/fcgiwrap.socket
 2165 root       828 S    /usr/bin/fcgiwrap -c 4 -s unix:/var/run/fcgiwrap.socket
 2166 root       828 S    /usr/bin/fcgiwrap -c 4 -s unix:/var/run/fcgiwrap.socket
 2216 root      1108 S    sleep 5
 2234 root      1112 S    sleep 5
 2239 root      1108 R    ps
 2240 root      1156 S    ubus call mwan3 state
 2241 root      1256 R    /bin/sh /usr/libexec/rpcd/mwan3 call state
 2516 logd      1068 S    /sbin/logd -S 64
 2568 root      1996 S    /sbin/rpcd -s /var/run/ubus/ubus.sock -t 30
 2693 root      2832 S    {repeater} /usr/bin/lua /usr/sbin/repeater
 2962 root       864 S    /usr/sbin/dropbear -F -P /var/run/ -p 22 -K 300 -T 3
 3132 rpc       1112 S    /usr/sbin/rpcbind -f -w
 3180 root      4892 S    /usr/sbin/hostapd -s -g /var/run/hostapd/global
 3181 root      4844 S    /usr/sbin/wpa_supplicant -n -s -g /var/run/wpa_supplicant/global
 3251 root      1600 S    /sbin/netifd
 3390 root      1248 S    /usr/sbin/odhcpd
 3505 root      1112 S    /usr/sbin/crond -f -c /etc/crontabs -l 5
 3685 root      1112 S    /usr/sbin/crond -f -c /tmp/gl_crontabs -l 5
 3843 root      1344 S    /usr/bin/dbus-daemon --system
 4123 root         0 IW   [kworker/1:2-eve]
 4128 nobody    1824 S    avahi-daemon: running [GL-A1300.local]
 4169 root       976 S    qcm -4 -s
 4274 root      1108 S    udhcpc -p /var/run/ -s /lib/netifd/dhcp.script -f -t 0 -i wwan0 -x hostname:GL-A1300 -C -R -O 121
 4367 root      6696 S    nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf -g daemon off;
 4380 root         0 IW   [kworker/u8:2-ev]
 5070 root      9312 S    nginx: worker process
 5071 root      9372 S    nginx: worker process
 5072 root      9372 S    nginx: worker process
 5073 root      9396 S    nginx: worker process
 5109 root         0 RW   [kworker/u8:0-ev]
 5110 root         0 IW   [kworker/0:1-mm_]
 5375 root      1332 S    /bin/sh /usr/sbin/mwan3rtmon
 5601 dnsmasq   2608 S    /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf.cfg01411c -k -x /var/run/dnsmasq/
 5626 root      2600 S    /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf.cfg01411c -k -x /var/run/dnsmasq/
 7514 root         0 IW   [kworker/2:0-eve]
 7550 root      1292 S    /bin/sh /usr/bin/gl_led
 7858 root      1112 S<   /usr/sbin/ntpd -n -N -S /usr/sbin/ntpd-hotplug -p -p -p -p
 7935 root       812 S    /usr/bin/carrier-monitor
 8046 root      7644 S    {gl_clients_upda} /usr/bin/lua /usr/bin/gl_clients_update
 8460 root         0 IW<  [kworker/u9:1]
 8462 root         0 SW   [lockd]
 8627 root         0 SW   [nfsd]
 8628 root         0 SW   [nfsd]
 8629 root         0 SW   [nfsd]
 8630 root         0 SW   [nfsd]
 8631 root         0 SW   [nfsd]
 8632 root         0 SW   [nfsd]
 8633 root         0 SW   [nfsd]
 8635 root         0 SW   [nfsd]
 8642 root      1000 S    /usr/sbin/rpc.statd -p 32778 -o 32779 -F
 8643 root      1388 S    /usr/sbin/rpc.mountd -p 32780 -F
10584 root      4004 S    /usr/sbin/usbmuxd --systemd
11771 root      1248 S    /bin/sh /usr/sbin/mwan3track modem_1_1 wwan0 online
13739 root      794m S    /usr/sbin/tailscaled --port 41641 --state /etc/tailscale/tailscaled.state
16502 root         0 IW   [kworker/0:2-eve]
18683 root         0 IW   [kworker/2:2-eve]
23374 root         0 IW   [kworker/3:2-eve]
27843 root         0 IW   [kworker/0:0-eve]
29621 root         0 IW   [kworker/2:1-eve]
29900 root       920 S    /usr/sbin/dropbear -F -P /var/run/ -p 22 -K 300 -T 3
30004 root      1116 S    -ash
30930 dnsmasq   2676 S    /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf.cfg01411c -k -x /var/run/dnsmasq/
31528 root       920 R    /usr/sbin/dropbear -F -P /var/run/ -p 22 -K 300 -T 3
31741 root      1116 S    -ash
root@GL-A1300:~# killall qcm

and this is syslog… (11.2 KB)

For XE300 with built-in modem, we have written a daemon to repair the abnormal status of the modem, but for the device with external modem, there is no such function, mainly because the model of the external modem is unpredictable, and the daemon may cause other exceptions.

what are the cat6 modems that work correctly via usb?

you can know how the modem is managed via usb, which daemons are called to reload, for example, routes, dns …

The problem I’m having is this…

I bought an EP25-E module and it seems to work fine with version 4.2.1. It manages to obtain the release of the provider automatically.

I also tested on a raspberry with both USB modules (EP06-E and EC25-E) and it works correctly. Both with openwrt and Raspian OS. Also with Raspian, I managed to get them to work with NetworkManager as well.

I wonder why EP06-E fails to work properly on this modem model.

Waiting for some info from support.

bad news! Same problem with EC25-E too. At this point I ask that the gl-inet firmware does something anomalous and is unable to update the lease of the quectel modems.
This is proved by the fact that by installing openwrt on a raspberry (same version), everything works correctly and the lease is quietly updated.
I mean that the XE300 model, which mounts the EP06-E modem, works correctly.

I am experiencing the same issue with my GL-MT3000 and USB connected Quectel RM520N-GL. Definitely seems to be a bug on the GL side as I’ve used this same modem in the same USB sled with other OpenWrt based routers with no issues. I sent all of the details to although I have not heard anything back.

Let me know if there is anything I can do to help troubleshoot the issue. I am in a similar situation where I rely on reliable connectivity for remote work.

The problem is the inability to update the provider’s “lease”. The provider often changes the IP and therefore fails to update. Of course you can make a script with a cron that periodically checks for updates but the truth is that if I use pure openwrt, it works.
Also I have seen that the software provided by quectel for operating the modem works correctly.

I’m only sorry that the support doesn’t answer because I can keep the modem by the 22nd of this month, otherwise I’ll give it back to amazano. Also because it says in the documentation that they support quectel modems. I tried ec25 and ep06 and it didn’t work.

You can run the commands (as in the picture) and see if the IPs don’t match for you too, why doesn’t it update the lease?

In my case the provider (T-Mobile) requires ipv6 so the output from your commands won’t show the IP mismatch because of the IPv6 NAT. But the issue is still the same, the interface must be bounced in order to obtain a new IP lease. Again, since I am using ipv6 (NAT6) I usually just disable and then re-enable ipv6 under Network > IPv6 which restores internet connectivity.

try running these commands and reporting the output:

/lib/modules/$(uname -r)/q*

also start installing this package: “kmod-usb-serial-qualcomm” and restart your modem meanwhile.
I’ll try to fix the bug tomorrow. If I can post the fix here

The command errors out with permission denied

root@GL-MT3000:~# /lib/modules/$(uname -r)/q*
-ash: /lib/modules/5.4.211/qmi_wwan.ko: Permission denied

I did install the kmod-usb-serial-qualcomm package and rebooted the modem.

Package: kmod-usb-serial-qualcomm
Version: 5.4.211-1
Depends: kernel (= 5.4.211-1-86cd10224392f0f1f47de97edd009387), kmod-usb-serial, kmod-usb-serial-wwan
Status: install user installed
Section: kernel
Architecture: aarch64_cortex-a53
Size: 3607
Filename: kmod-usb-serial-qualcomm_5.4.211-1_aarch64_cortex-a53.ipk
Description: Kernel support for Qualcomm USB Serial devices (Gobi)
Installed-Time: 1684357311

Do you mean

ls /lib/modules/$(uname -r)/q*

Yes, but still I managed to figure out that it only had one file.
But did you understand why I can’t update the lease? because every hour I have the disconnect.

GL support provided me two updated scripts that so far seems to have resolved my issue.

@alzhao can I attach the two files with instructions provided by support to this thread?

Yes, you can post here.

It seems to have a different issue.

Hi eros23:
This is due to a change in Cellular ip.

Hi eros23:
After two days of testing, A1300+EP25-E performed OK.

Can you consult the supplier of EP25-E and EC25-E to check whether the firmware can be updated?

This lease is also usually obtained from Cellular(EP25-E,EC25-E). But it looks like the Cellular’s IP was renewed before the lease expired.