GL-AR300M-Lite + USB Wifi again

Is it possible to disable the onboard WiFi? Either programmatically, by configuration or by removing the wifi driver.

My use case is similar to a number of posts on this forum. I am building external cellular and WiFi antennas for my camper trailer. They will be mounted on a mast outside extending about 12 feet high. They should improve performance when camping in remote areas.

I have successfully used a USB 4G modem (Sierra EM7455) with my GL-AR300M-Lite.

USB WiFi is my problem. I’d like to use a USB WiFi 2.4GHz adapter connected to an external antenna. I have installed the driver packages (ath9k) for the USB adapter chipset (AR9271). The onboard WiFi appears as radio0 and the USB adapter as radio1. However, after connecting radio1 to my home WiFi, I have difficulty getting an Internet connection via the GL-AR300M-Lite ethernet port.

It doesn’t matter to me if the onboard WiFi is completely disabled. I’m only interested in the higher performance of the USB adapter and external antenna.

Has anyone done this successfully? What steps did you take?

Thanks in advance.


The only way I have been successful using a USB WIFI adapter with a similar GL-AR300M16 router was to give up on the GL iNet firmware and go with OpenWrt 19.07.7 firmware. I am using a Panda PAU08 USB WIFI adapter which was cheap and has very good range. Here is a link to a post I wrote asking for better support of USB WIFI adapters in the GL iNet firmware, that includes pointers to other people who have experienced the same problems when trying to use USB WIFI adapters: Support for USB WIFI Adaptors


Can you share your config, mainly the following files


It should be a problem of config and easy to be solved.

Could you make this work out?

Hello, I have exactly the same issue with a Atheros AR9271 USB Wifi adapter. Is there a solution by now ? Thank you.

1 Like

I think there is only configuration issue. So describe details and post config to check.