GL-AR300M - no internet access


Have just upgraded my GL-AR300M’s firmware from 2.2. to 3.024 because I don’t get internet access when connecting the minirouters OpenVPN client to my Asus’s OpenVPN server at home. This works perfect, and when connecting via wifi to the minirouter I have full access som my home. But “no internet access”.

This has worked earlied, but for unknown reasons it seems to stop.

Port 83 is not open, but I assume this is only of importance if I want to connect the other way, ie from my home to the minrouter to aministrate it remotely.

What can I do to re-establish the internet connection?

Can you take a look at your firewall and network configuration?
The /etc/config/firewall and /etc/config/network.

i have not changed anything in the configuration. It has worked before, but suddenly no more. As mentioned I can connect just fine to my home and log in to the router here. But when connecting via wifi to the mini-router it says “No internet access”. If this was a firewall issue I assume that I wouldn’t even be able to connect to the home server.

If you don’t have a particularly important configuration to keep, I suggest you restore the router to factory Settings.

I had this exact problem. Spent agesss checking firewall and route settings with no success.

What fixed it for me was switching from Router mode to Access Point mode, then back to Router mode again. This setting is found in the GL.iNet webUI under “More Settings” → “Network Mode”.

I hope this helps anyone else who encounters this in the future.