GL-AR300M not recognising Huawei E3372 USB Modem


#1

Hi I can see that the Huawei E3372 modem is approved. When I plug my E3372 in the AR300M says ‘plug modem in’!

I have done a full reset but with no change. The Huawei works OK into my TP-Link DSL modem by the way and laptop.

Everything else works perfectly especially OpenVPN and I am very pleased with this little box!

Anybody got any ideas why the 3G/4G implementation is not working for the Huawei E3372?


#2

Are you running the latest firmware? I saw the same issue with my Netgear 770S until I updated to 2.261. Now it recognizes the modem.


#3

I upgraded to 2.261 but it still shows ‘Please plug in your modem’.

I have tried a Huawei E5573s which Tethers OK, but I really do want the Huawei E3372 to work in the 3G/4G mode.


#4

Seems there is too many models of E3372. Some works and some are not.

Can you share the carrier info? Generally the modem is sold by the carrier and it works with the carrier without problems.

We are testing some modems for Verizon US but there is no E3372.


#5

Hi Alzhao,

I purchased the E3372 from Ebay as unlocked and it does work with a 3 sim (UK) as well as a Bouygues Tel sim (France) both into a MacBookPro and into a TP-Link VR600V into the USB socket.

I’ve attached two screen shots of the device info from the E3372 for your information.


#6

Hi Alzhao,

Another thought, if the Huawei E3372 is going to be problematic would a ZTE MF823 be a better bet?

I do have a 35 dBi gain attached to give me a signal because I am in a patchy rural area in France!

Having said that I have found that the Huawei is a good modem with a very good receiver front end. I find that I can hang onto a weak 4G signal with the E3372 which is not the case with a TP-Link MR200 that drops the signal at any excuse! (Both connected to the high gain antenna)

How does the ZTE ME823 compare to the Huawei E3372 in your experience?


#7

I don’t have too much experience in these modems except for had a testing before.

Do you think it is possible to send your E3372 to me so that I check/add support and send you back?


#8

Hi Alzhao

I don’t see why not! I am in France until the middle of next month and need the E3372 while I am here, but when I am back in the UK I have no need for it so can send it to you. Where are you? The UK has far more cheap postage options than France does!

Ian


#9

@Ian:

Any chance of posting a photo of your hi-gain set-up?
Also, how far away are you from the telecom tansmitter?

Regards,
Glitch


#10

Hi Glitch

Photo attached. It is an Ebay purchase from a Polish guy based in the UK who gets them made in Poland!

I don’t have any specific details which is a shame, but it does work!

Twin downlead by the way.

I ‘think’ I am about 6kms from the mast, but as this is France I can’t be sure exactly where the mast is!

I have been trying to find a program to show the signal strength in real time on either a Mac or PC but sadly can’t find anything useful.

So tweaking the antenna to get the best signal isn’t easy!

The Huawei is much more ‘open’ when it comes to seeing signal strength, the TP-Link was impossible, as TP-Link don’t let you get to the inner workings of the chipset!

Ian


#11

@ianmenai, I need that modem send to HK, is that possible? I can pay the two-way shipping


#12

@ Ian
Thanks for the photo - nice piece of kit!~
Is it dual SMA, and if so, where do the two leads connect to? Any chance of a photo of this too?

Glitch


#13

Hi Glitch

The antenna is terminated with two FME Female connectors about a metre from the antenna.

I took the option of the longest feeder cable - 15 metres - (Every metre of cable drops the signal level and 15 metres is considered the maximum length.) At the same time I ordered two FME Male to TS9 cables as well as a couple CRC9 to FME Male and two FME Male to SMA cables. All are ‘jumper’ cables and are about 30cms long.

The CRC9 converts to the Huawei E3372, the TS9 ones are for my Huawei E5573 and the SMA set is for my somewhat useless TP-Link MR200!

Hope this is helpful.

Ian


#14

<span id=“result_box” lang=“en”>hello all, the same problem, I bought a usb lte huawei E3372 key but my mt300a does not recognize it, the latest firmware installed on the 2.261.
Who would be the person who tested this E3372?
Is it useless to try out the latest firmware versions?
What alternative can you point to instead of the E3372</span><span id=“t-served-community-button” class=“trans-verified-button goog-toolbar-button” style=“display: none;”></span>


#15

Hello, i solved the problem.

Change the ip from Advance setting, 192.168.8.1 to 192.168.12.1.

Connect use tethering.


#16

Well I’m back in the UK and thought I would try a friends ZTE MF823 dongle.

Sad to say that it still says ‘Please plug in your modem’!

So that is both a Huawei and ZTE that are not recognised!

I’m beginning to think that the GL-AR300M could be faulty?

Any thoughts?

Ian


#17

I should add that this is what I see under the Tether Tab.

 


#18

There is no connection to the internet by the way!

Looking at the dongle, be it the Huawei or the ZTE, it shows that a 4G connection is made but doesn’t get through the GL-AR300 router to my MacBookPro!


#19

Hello,

I have an identical problem with the Huawei E3372 and the gl-ar300m.
In fact exactly similar down to connecting to “3” in the UK, and similar in France.

All the screenshots would be exactly the same too!

Has the problem been solved? And how?
Thanks, Barry


#20

Try changing your router’s IP from 192.168.8.1 to something else and try again.