GL-AR300M Port Forwards not working

I use these units at scale so this is not a a misconfiguration problem. We follow simple port forward procedure to set them up, and normally they work fine, however every now and then the port forwards will just not work on a unit, no matter how many factory resets/firmware updates are performed. We can have many of these units connected as repeaters to the same building WiFi network. What could possible be happening?

The router has outbound connectivity, but the port forwards just refuse to work when trying to connect from the upstream network.

I repeat: We configure multiple units every day and they work fine. What could be causing a particular unit configured the same way not to work? Could this be a hardware issue? What would the recommended steps be to debug or fix this?

So you have a lot of routers as repeater and set up port forward in your main router.

If you set up portforward from your main network, pls tell us how did you set, e.g. forward which port to which port and IP.

Can you give more info which configure does not work?

After taking the router out of its box and powering it up, we change the default SSID (for example, from GL-AR300M-000 to Router7) and LAN IP address so it is on the 10.66.171.x range, then set up a couple port forwards, for example 8080, to point to an internal address, (for example We also scan and connect it to our building WiFi network (let’s call it BuildingNetwork), which will assign the router an IP address on the 192.168.1.x range, for example
Because the computer on has a web server on port 8080, I can access that content if I connect directly to the router by connecting to SSID Router7 and go to
Normally, If I connect to BuildingNetwork, I can access the same content if I go to, because the port forwards are in place. But on this particular unit they just don’t work, they time out. Most ironically, however, I can access the content by connecting to Router7 directly and opening Also, the computer on HAS internet connection, so it IS successfully connected. But the port forwards don’t work as they usually do.

Looks so strange.

If the router use the same firmware as other units, this must work. If it does not work, seems there are something wrong. Can you change 8080 to other ports and try?

I did try changing 8080 to a different port, but still the same.

I even downloaded and manually reverted to an earlier firmware version. Also tried adding the port forwards in Luci instead, but nothing worked.

Further investigation shows that the problem is not with the port forwards, but with the router functionality instead. I replaced the unit and I’m still seeing the same behavior. Moreover, I tested with replacing the “BuildingNetwork” with a different AR300. I can connect my “destination” AR300 to a different “intermediate” AR300 and in the Admin Panel of the “Intermediate” I see the “destination” among the clients in the 2.4G Wireless section. But I cannot ping the “destination” directly from a different client connected to the “intermediate”, and it does not show up on port scans. But if I ssh into “intermediate”, then I am able to ping “destination”.

What could possibly be going on?

Could it be related to this:

Could it be related to the ap_isolate mode? Why did it use to work but now it doesn’t??

The issue has been solved, and it was not being caused by the router but by some conflict from a device connected to it.

1 Like