GL-AR300M - Tor Set Up


I just purchased GL-AR300M and want to set up Tor.
Can someone explain how to set up in details?

From control panel, I clicked “App repo” then installed following 3 software.

  • tor
  • tor-fw-helper
  • tor-geoip

Now what? Am I doing it wrong?


according to here: OpenWRT · Wiki · Legacy / Trac · GitLab

change /etc/config/firewall and /etc/firewall.user

then reboot

Do I need to do it via SSH?

When do you plan to release the firmware with Tor configured?

Hello, any update?

OK. I will renew the Tor firmware next week, so no need to talk about how to configure it.

Tor on AR300M

after opkg install tor and config on torrc file, the tor service is still not running? netstat -a | grep tor

tried /etc/init.d/tor enable and /etc/init.d/tor start , nothing in /var/log/tor/notice.log

super weird? everything else runs fine

does anyone got Tor running on AR300M?


I see the exact same issue on AR300M, no log, no messages anywhere. Tor service won’t start. /var/run/ is also empty.

I had the same problem with AR-300M 2.22 firmware and the 2.23 testing version.

I’ve compiled a custom firmware with master branch of openwrt package repository and now everything is working as expected.

@fanboyslim, can you publish the compiled binary? Did you compiled the firmware, installed it on AR-300M and then install tor from the repository?

Also, how did you manage to compile the firmware for NAND flash?

Thank you


Cool! Can you post a little help? Just the juicy commands from your command history. If you have the time? And want to help some fellow Tor freaks :slight_smile:


Today I’ve recompiled the firmware with the last version of tor (2.8.9). Prior versions have a critical bug (Tor is released, with important fixes | The Tor Project).

@ylame I recompiled the firmware with de tor package already installed.

I’ve got almost a “vainilla” openwrt firmware so after update ar-300m, you have to do manual configuration of wireless ap, install luci package (to get web ui)… Install luci is a important step to easy update firmware next time.

Access ip is through lan cable (wireles is disabled by default) and you have to telnet first to set root password (OpenWrt – First Login [Old OpenWrt Wiki])

You can download the firmware (2.8.9 tor version) from


Please, don’t update if you don’t know what are you doing. I’ll not support this firmware compilation. I’m sure alzhao release a new tor firmware with better default configuration for ar-300m soon.


@fanboyslim, This is exactly what I’m looking to do as well. Can you please let me know what config you selected during make menuconfig for building the firmware for AR-300M NAND as this router is not officially available in openwrt toolchain.

I’ve coppied the network and wireless config files from GL Openwrt firmware and plan to use them during building the firmware.

Thank you

I followed the steps from docs Overview - GL.iNet Docs with minor changes.

$ sudo apt-get update

$ sudo apt-get install subversion build-essential git-core libncurses5-dev zlib1g-dev gawk flex quilt libssl-dev xsltproc libxml-parser-perl mercurial bzr ecj cvs unzip git wget ####I’m in Fedora 24 but I’ve not had any problem installing dependencies####

$ git clone GitHub - domino-team/openwrt-cc: openwrt CC with Domino/GL patches

$ cd openwrt-cc

$ vi feeds.conf.default ####remove “;for-15.05” of feeds to point master branch of openwrt packages#####

$ ./scripts/feeds update -a

$ ./scripts/feeds install -a

$ vi feeds/packages/net/tor/Makefile ####Point to last version of tor in package (PKG_VERSION:= PKG_RELEASE:=1 PKG_MD5SUM:=e1f8bc2b2e2b365fc916388304e5e40d)#####

$ make menuconfig

…choose your compile target ####Subtarget: Generic devices with NAND flash; Target Profile: GL-AR300M NAND### and packages ###select tor package as include in image####

$ make

Thank you fanboyslim, I did follow this doc and build it but was missing the step to update the feed. I’ll re-try with your steps.

Thank you for sharing.

I just completed make, strangely it did not generate sysupgrade image (.tar) there is on .bin and also it generated bin’s for all router profiles.

@fanboyslim any thoughts?



I think you forgot set

Subtarget: Generic devices with NAND flash;

Target Profile: GL-AR300M NAND

in make menuconfig. Maybe?

@fanboyslim Thank you for quick response, I made and typo in naming the .config file, it was using the default. Just completed the make about to upload.

Thank you once again.


Thanks to @fanboyslim, I now got the latest tor running.

Do you know if it is possible to include Luci in the build? i cant find the luci packages in the menuconfig?


Dear all, hope this is not too late. I just updated the Tor firmware. Please check: Overview - GL.iNet Docs

New Tor firmware is with Domino UI and Luci

Hi, thank you for the firmware.

I tried to flash the firmware but I’m confused with the Uboot instruction.

It says “Connect only one cable to your router, and leave the other LAN port unconnected.”
So I connected Only WAN cable, LAN side disconnected, but the youtube video shows only connecting LAN cable not WAN.
Which is correct?