GL-AR300M Wireguard Client

I am trying to connect to my pivpn wireguard setup and the router will never connect. I have copied and pasted the conf file directly from the pi into the web text box. This same .conf file works on the wireguard app on my phone. Below is my conf file with any keys or endpoints taken out.

PrivateKey = ********************************************
Address =

PublicKey = *********************************************
PresharedKey = ******************************************
Endpoint =
AllowedIPs =, ::0/0

Any help would be greatly appreciated

How about that: [GUIDE] Connect to cloudflare's free WARP pseudo VPN service using built-in wireguard client

Also did you check on or similar sites if it’s might just the Router-UI which shows disconnected but Wireguard is working fine? That happened to me quite often when I used a beta firmware or a snapshot, but fixed itself after a few days.

good luck.

Try rebooting the router after creating the config. Also try using the manual input option instead of the text box. BTW the manual input will only accept for the allowed IPs (though you can change it after the fact - I’m not sure how well IPV6 is supported on gl.inet’s wireguard currently though).

Basically there is no global ipv6 support in the GL firmware for now, be it VPN, or other things. That will change in the future, but for now its not supported.

Can you provide me with a wiregaurd configuration file, I will test it for you , my email address

Hey, @themana just wondering if you were able to resolve this issue? I also can’t get my router to connect to my Wireguard PiVPN server. Thanks

Firmware Version 3.201
My pivpn config looked like

PrivateKey = xxx
Address =
MTU = 1420

PublicKey = xxx
PresharedKey = xxx
Endpoint = xxx:51820
AllowedIPs =, ::0/0

I had to enter a „new line“ after line „ Address =“ and before „MTU =“.

With this minor change, I was able to import config file in the text-field!