GL-AR750S delivered!

Ooh… just waiting to be opened!


Everything needed for travel!

Nice size. Has a good, solid feel but is very lightweight.

Size comparison to the GL-AR300M.

Time to start playing!!!


I missed the first wave but got in on the 2nd wave. I got an E-mail last week saying mine would be delivered “in a few weeks” so this is encouraging yours is here already!

1 Like

I’ve been playing around with this in repeater mode (just in my home network) and it’s been really solid so far. I’ll be in Taiwan next month so it will really get a test there (I live in the US and set up both OpenVPN and Shadowsocks servers on my router).

My AR300M performed flawlessly which I was in Japan, Korea, Taiwan and China so I’m excited to give this one a go!!!

1 Like

Will you try wireguard? It is faster than vpn and ss.


My router does not have a Wireguard server for it yet which is why I use OpenVPN or ss. I may try setting up a wireguard server on a different computer at my home but ideally I’d like an option that can run on my router.

1 Like

I generated a CONF on AzireVPN but pasting in the contents on AR750S when adding a WireGuard Client results in an error - “ERROR: Config error”. It might be failing because listening port is missing? When I go to Manual Input instead using the contents of AzireVPN’s CONF file for Wireguard, it had listening port as a required field on AR750S and that is the only thing missing from the CONF provided by AzireVPN. I just put in a random port for that while plugging in the other data from the CONF file in the appropriate fields, and then it claimed success but now I have no access to the internet although it says connected. I even tried the last of the 3 options called “Others” which has a built-in Provider azirevpn, so I put in username and password that I used to register on their website, but it says “Invalid Username or Password”. I registered two separate accounts just in case I had messed up the username/password during AzireVPN registration, and it still fails for this same reason…I am copy/pasting the password from LastPass so it is not a user error. I cannot get Wireguard to work with AzireVPN with AR750S, I don’t think it is ready.

Aside from Wireguard, button set to enable VPN on boot doesn’t work for AR750S (button settings is OpenVPN/Client toggle on/off, and I have the button slid to the left as in the picture in admin GUI)), I have to enable OpenVPN manually each time.

Finally, it would also be nice if the GUI showed something when a microSD card is successfully inserted and working - I can access SD card via SMB but can’t see anything on Admin Panel about it working.

1 Like


#1 Configuration tab: Oops, this tab only support the configuration file which is generated from our wireguard server. We should compatible with the regular wireguard configuration. Will done next release.

#2 Wireguard Connected: If it shows connected, it should be works. Could you ssh into the router, and issue ip route showwgmwan3 statusping and report the result?

#3 AzireVPN username and password works for me, could you pls send a message with your username and password? I will test it.

#4 I will check out the button issue on boot.

Yup, will fix next release.

#3 - I finally got it so it says “Success” but then nothing happens - it doesn’t keep the AzireVPN defined, the only thing I see in Wireguard Client after adding a profile is “Add new Profiles”, as though it is not actually saving the profile despite the claim of success. I will PM you my user/pword for AzireVPN just in case it helps.

#2 - I’ll look into doing this tomorrow, lot of things going on tonight.


I have confirmed that there is a buggy that password with special characters. We have fixed it. Pls reinstall gl-wg ipk. Going to webui → APPLICATIONS → Plug-ins, search gl-wg, click uninstall button and then click on update button which is located in right top. Finally install gl-wg again.

Hi ,
Sorry OP but I will post in this thread as it is about AR750s.
I one of the happy ones to get my router on Friday but only today I had time to play with it.
I love the new UI and for sure it is a nice lovely toy for my future trips.
For now, Uploading the OpenVpn profiles from PureVPN seems to not work so smooth. I have tried to upload the .zip package as it comes from PureVpn ,on the old UI on a AR300M it works without issues so I do presume it must be something with the archive processing step.
Screen shot attached at the end of the upload process.
It is not bothering me as of now but I wanted to put it out as a problem that needs a solution :slight_smile: .

L.E.: I have tried now to upload manually the configs ( one by one) and the same thing seems to happen.
Anyone experiencing the same?

@lostdog - IMHO , ExpressVPN and PureVPN seem to have a great service from Taiwan ( You are located in Taiwan and try to use a VPN server outside Taiwan.) I live part of the time in Taiwan so I thought I will give you a heads up :slight_smile: .

@misujr - I’m actually in the United States but travel to Asia regularly for business. I’ll be in Taiwan next month for a semiconductor conference then may stop in Shanghai on my way back to the states. I use these routers to connect back to a VPN server at my home.

So far I’ve connected to both OpenVPN and Shadowsocks with no issue… Great little router!!!


Only .ovpn files are supported in the UI.

Follow this guide on how to merge the ca, cert and key files into the ovpn file:

If you open your cert file and you see blocks like this:


Then you can ignore the part of converting in the guide linked, just paste those blocks.

Your config should look like this:

Blame your provider for not using the latest method of creating config files :stuck_out_tongue:

@misujr Could you unzip the archive manually? Does it only Includes .vpn files or .vpn with certificate file? BTW, can’t put the .vpn files in subdirectory.

@lostdog thanks for the pictures. Are the antennas removable?

Nope, but they fold down flat against the side when you don’t need them. Very low profile and a good design!

Yep although there are several bugs in v3 (I am happy to say dev team is tackling very fast for me), I must say Slate feels very high quality and the new AR750S has already replaced my ar300m by a long shot. I had openvpn connectivity issues I no longer see on v3 beta.

Thanks a lot. We really appreciate your kind and reviews. We will continue to focus on stability and availability.

Hi, there is a problem in 3.0UI. When your zip file contains a folder the opvn files will not be detected.

So, put your ovpn files and cert files in the root folder and zip them. Then upload

This doesn’t work —> config/*.ovpn

This works —> *.ovpn

1 Like

I’m curious about the shipping method between the two batches of orders … I got in on the 2nd wave, but it sure seems like the first-wave people needed to wait a lot less time for end-to-end shipping than us 2nd-wavers; I got a notification mine was shipped on Aug 7th (ordered on July 19th) and my device just got to the US from China, VIA Germany (kinda funny as I live in Cali), so far two weeks and counting in transit.

How long did it take for shipping (vs. actual order fulfillment) for the first-wave folks?

It’d be nice to have my Slate before I leave on a trip next Monday :slight_smile: