GL-AR750S-Ext and Huawei E3276s-150

Hi all,

I’ve a GL-AR750S-Ext router and a Huawei E3276s-150 LTE modem.
I’m trying to connect to Internet via the LTE modem but I cannot.
The router seems to recognize the modem well (some outputs)

dmesg

[  516.401995] usb 1-1.1: new high-speed USB device number 9 using ehci-platform
[  516.560231] usb 1-1.1: New USB device found, idVendor=12d1, idProduct=157c
[  516.567398] usb 1-1.1: New USB device strings: Mfr=5, Product=4, SerialNumber=7
[  516.574972] usb 1-1.1: Product: HUAWEI Mobile
[  516.579483] usb 1-1.1: Manufacturer: HUAWEI Technology
[  516.584816] usb 1-1.1: SerialNumber: FFFFFFFFFFFFFFFF
[  516.628063] usb-storage 1-1.1:1.0: USB Mass Storage device detected
[  516.646802] scsi host0: usb-storage 1-1.1:1.0
[  516.652074] usb-storage 1-1.1:1.1: USB Mass Storage device detected
[  516.669957] scsi host1: usb-storage 1-1.1:1.1
[  517.282624] usb 1-1.1: USB disconnect, device number 9
[  517.642154] usb 1-1.1: new high-speed USB device number 10 using ehci-platform
[  517.823825] usb 1-1.1: New USB device found, idVendor=12d1, idProduct=1506
[  517.830989] usb 1-1.1: New USB device strings: Mfr=5, Product=4, SerialNumber=0
[  517.838671] usb 1-1.1: Product: HUAWEI Mobile
[  517.843200] usb 1-1.1: Manufacturer: HUAWEI Technology
[  517.963187] option 1-1.1:1.0: GSM modem (1-port) converter detected
[  517.969952] usb 1-1.1: GSM modem (1-port) converter now attached to ttyUSB0
[  517.977946] option 1-1.1:1.1: GSM modem (1-port) converter detected
[  517.984820] usb 1-1.1: GSM modem (1-port) converter now attached to ttyUSB1
[  518.134594] huawei_cdc_ncm 1-1.1:1.2: MAC-Address: 0c:5b:8f:27:9a:64
[  518.141223] huawei_cdc_ncm 1-1.1:1.2: setting rx_max = 16384
[  518.178542] huawei_cdc_ncm 1-1.1:1.2: setting tx_max = 16384
[  518.203544] huawei_cdc_ncm 1-1.1:1.2: NDP will be placed at end of frame for this device.
[  518.212281] huawei_cdc_ncm 1-1.1:1.2: cdc-wdm0: USB WDM device
[  518.219327] huawei_cdc_ncm 1-1.1:1.2 wwan0: register 'huawei_cdc_ncm' at usb-ehci-platform.0-1.1, Huawei CDC NCM device, 0c:5b:8f:27:9a:64
[  518.232967] usb-storage 1-1.1:1.3: USB Mass Storage device detected
[  518.422082] scsi host0: usb-storage 1-1.1:1.3
[  518.427417] usb-storage 1-1.1:1.4: USB Mass Storage device detected
[  518.494020] scsi host1: usb-storage 1-1.1:1.4
[  519.512761] scsi 1:0:0:0: Direct-Access     HUAWEI   TF CARD Storage  2.31 PQ: 0 ANSI: 2
[  519.523407] scsi 0:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[  519.535819] sd 1:0:0:0: [sda] Attached SCSI removable disk
[  524.596623] 3g-modem_1_1: renamed from ppp0

cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=02 Prnt=08 Port=00 Cnt=01 Dev#= 10 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=ff MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1506 Rev= 1.02
S:  Manufacturer=HUAWEI Technology
S:  Product=HUAWEI Mobile
C:* #Ifs= 5 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=10 Driver=option
E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=12 Driver=option
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:  If#= 2 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=85(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
I:* If#= 2 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=85(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

ifconfig -a

wwan0     Link encap:Ethernet  HWaddr 0C:5B:8F:27:9A:64  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

but the configuration written by the Web GUI doesn’t work

cat /etc/config/network

config interface 'modem_1_1'
	option ifname '3g-modem'
	option service 'umts'
	option apn 'iliad'
	option proto '3g'
	option device '/dev/ttyUSB1'
	option dialnumber '*99#'
	option metric '40'
	option disabled '0'

How can I fix?
I’ve none experience with OpenWRT.

This might help:

How? My modem is already in “stick mode”.

[EDIT]

Googling …

https://forum.openwrt.org/t/direct-network-mode-for-hilink-e3276-4g-stick/11399/4

… I found this configuration is partially (*) working

config interface 'modem_1_1'
	option ifname 'wwan0'
	option mode 'umts'
	option apn 'iliad'
	option proto 'ncm'
	option device '/dev/cdc-wdm0'
	option dialnumber '*99#'
	option metric '40'
	option disabled '0'

I edited /etc/config/network manually and restarted the network with the command

service network reload

(*) only if the modem is connected to router before the boot.

Any hint?

Another issue: sometime using the above the router is connected to Internet, host connected to router not.

Some output of the router

ifconfig

br-lan    Link encap:Ethernet  HWaddr 94:83:C4:05:23:6B  
          inet addr:192.168.8.1  Bcast:192.168.8.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6121 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6268 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:597436 (583.4 KiB)  TX bytes:4338150 (4.1 MiB)

          ...

wwan0     Link encap:Ethernet  HWaddr 0C:5B:8F:27:9A:64  
          inet addr:10.152.27.181  Bcast:10.152.27.183  Mask:255.255.255.252
          inet6 addr: fe80::e5b:8fff:fe27:9a64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:298 errors:0 dropped:0 overruns:0 frame:0
          TX packets:499 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:27487 (26.8 KiB)  TX bytes:39439 (38.5 KiB)

route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.152.27.182   0.0.0.0         UG    40     0        0 wwan0
10.152.27.180   0.0.0.0         255.255.255.252 U     40     0        0 wwan0
192.168.8.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

ping -c 4 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=114 time=460.507 ms
64 bytes from 8.8.8.8: seq=1 ttl=114 time=1260.782 ms
64 bytes from 8.8.8.8: seq=2 ttl=114 time=940.412 ms
64 bytes from 8.8.8.8: seq=3 ttl=114 time=100.170 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 100.170/690.467/1260.782 ms

ping -c 4 google.com

PING google.com (216.58.208.174): 56 data bytes
64 bytes from 216.58.208.174: seq=0 ttl=117 time=749.371 ms
64 bytes from 216.58.208.174: seq=1 ttl=117 time=79.237 ms
64 bytes from 216.58.208.174: seq=2 ttl=117 time=108.975 ms
64 bytes from 216.58.208.174: seq=3 ttl=117 time=95.544 ms

--- google.com ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 79.237/258.281/749.371 ms

Maybe I posted the wrong link…I was trying to say change the LAN IP of the A750S to something other than 192.168.8.1.

OK let’s make a summary.
This configuration partially works

config interface 'modem_1_1'
	option proto 'ncm'
	option ifname 'wwan0'
	option device '/dev/cdc-wdm0'
	option apn 'iliad'
	option dialnumber '*99#'
	option mode 'preferlte'
	# option delay '15'
	option metric '40'
	option disabled '0'

Router exits to Internet via modem but only if the modem is already connected to router before boot.
Ref: My modem doesn’t reconnect after it loses the connection
On router:

ping -c 4 8.8.8.8 ... OK
ping -c 4 google.com ... OK

Clients connected to router don’t exit to Internet but are connected to router
On clients:

ping -c 4 192.168.8.1 ... OK
ping -c 4 8.8.8.8 ... KO
ping -c 4 google.com ... KO

What’s there still to fix on the router? Bridge? Firewall?

Thanks

PS: I’ve none experience with networking on OpenWRT.

Did you try changing the LAN IP of the router?

Yes but nothing has changed. I have some experience in networking and frankly I have no idea how changing the subnet can help solve the problem.

add the modem interface to firewall wan zone so the routing happens for lan clients…

Can you give me some command or link to read to control and manage the firewall zones?

i’m on vanilla openwrt don’t know about glinet gui… you should go in advanced firewall for glinet gui i guess or ssh an add interface to /etc/config/firewall add your interface to option network

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 wan_6 lte lte_4 wwan0'

This should be the correct way to use modem, right.

You need to insert the modem to the router before boot.

@ bajave

Yesss

cat /etc/config/network
...
config interface 'modem_1_1'
	option proto 'ncm'
	option ifname 'wwan0'
	option device '/dev/cdc-wdm0'
	option apn 'iliad'
	option dialnumber '*99#'
	option mode 'preferlte'
	option delay '10'
	option metric '40'
	option disabled '0'
...

cat /etc/config/firewall
...
config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 modem_1_1'
...

good! please mark as solved for other users, consider installing vanilla openwrt since you use ssh/shell commands you don’t need gl.inet gui, much more information available for advanced users and you’ll learn a lot!

https://openwrt.org/toh/gl.inet/gl-ar750s