GL-AX1800 + AdGuard Home

I tried leaving it running for 8 hours. I had 9,940 DNS queries in that time. Domain resolution became unresponsive, network speeds dropped to unusable levels (not even testable).

Thank you very much for your feedback. I’m going to verify that.

I use adguard home :pensive:

I tried this command, my ax1800 memory never go down bellow 80% even i turn off adguardhome, but after i used that command my memory usage now become 70%.

As of the 3.207 update, AdGuard will no longer start.

1 Like

Confirmed same here. Internet access is disabled in my case since adguard is stuck in a limbo and I can only go online after disabling adguard then rebooting the router.

I am on 3.207 for few of days now and do not have any problems with AdGuard.

@alzhao I’m using 3.207, before running echo '3' > /proc/sys/vm/drop_caches my available memory is 8%. After running the command, available memory is 15%

Just updated to 3.207… A COMPLETE DISASTER! AdGuard Home won’t work. Have to disable it to get online…

Hi @briar-spoon-celibate :

Please update AdguardHome(0.106.3-1) in Plug-in.

Hi fmccann:

You should have updated AdguardHome.

Please reinstall AdguardHome(0.106.3).

Please reinstall AdguardHome(0.106.3).

After Reinstalling, I now get the error “API is unavailable”

Got the same error “API is unavailable” after upgrade my AdGuardHome to 0.106.3, rebooting the router doesn’t help either, now I can’t use AdGuardHome.

Try to install gl-agh-stats i think that’s needed as well



Sorry,gl-agh-stats was uninstalled due to uninstalled Adguardhome(0.104.3)

  • The procedure is as follows:
    1,Disabled Adguardhome,then unistall Adguardhome(0.104.3)
    2,install Adguardhome(0.106.3) and gl-agh-stats

Thanks @Exile1975 and @lizh I was able to upgrade AdGuardHome to 0.106.3 but I had to setup it again, my settings for 0.104.3 was cleared after the upgrade

After the update to 3.207, AdGuardHome did not work for me (version 0.106.3 was working before the update ). The Plugins page indicated the latest (0.106.3) was intalled and offered only the uninstall option.
However, in the ssh console, the system showed (opkg list-installed) version 0.104.3 was installed. Therefore, I ran opkg upgrade AdGuardHome, then /etc/init.d/AdGuardHome start and everything is working now.


Thank you I will try your fix and see how it goes. Appreciate the details very much.


Yes now with 4.2.1 works