GL-AX1800 (Memory leak)


Tested on 3.213, 3.214 (beta 2022-04-13 06:47:16) and previous versions.

1. Made a complete reset of the device
2. Set up an Internet connection (PPPoE)
3. Set up Wi-Fi (only use Wi-Fi)
4. Set up a VPN (AzireVPN) Wireguard

5. Configured VPN Policies (only Enable VPN Policy), used the list → (30.1 KB)
→ /etc/route_policy/domain_name/via_vpn

6. After rebooting the device, a memory leak occurs, reaches 98-99% and the router stops responding, it is impossible to access
7. Helps → Custom DNS Server → enable/disable → DNS Rebinding Attack Protection or Override DNS Settings for All Clients, the memory is normalized around 58-60%, this must be done before the memory reaches 95 or more.

Log (88.3 KB)

1 Like

Try to SSH into the router and enter

echo ‘3’ > /proc/sys/vm/drop_caches

1 Like

Thanks for reporting, will fix this asap.

1 Like

This bug has been fixed in latest testing verison.

1 Like

I have tested 2 versions of 3.214 beta firmware so far (0413, 0421), I found out that the qca-nss-ecm is disabled by default ? Does this mean that the NAT hardware offload function is turned off by default unless you turn it on manually ?

qca-nss-ecm is disabled if ipv6 is enabled. But almost no NAT performance penalty as the powerful cpu.
As a result, the cpu sirq increse from 0% to 30%.

I see, thanks for the explanation.

Thank you! problem solved! It would be nice to update AdGuardHome to the latest version)

1 Like