GL-AXT1800 crash after connecting to a 5Ghz Wifi

Hi all, newbie here.
I’m experiencing troubles with my GL-AXT1800 Slate AX. I connected to a 5Ghz Wifi6 network as a repeater for almost a day, then the router rebooted and connected to the same wifi ssid but in 2.4Ghz.

Now i’m unable to reconnect to the 5Ghz ssid anymore. From the admin web panel i don’t see the 5Ghz ssid, instead using Luci i can see the ssid but when i try to connect to it, the router crash, reboot and get stuck in boot loop and i have to reset it.
My specifics:
FW version: 4.0.1 release 3 updated from web admin upgrade tab
No AdGuard
No plugins installed
Set as router

I tried to separate

Can someone help me?

Thanks in advance

Try the 5.4 kernel firmware and it does not crash.

Hi and thanks,
i tried to flash the kernel 5.4:

the result is a bricked router that i had reset using uboot reflash approach.

Can you suggest me another way to install that kernel?


Thanks for the suggestion,
the second attempt of flashing kernel 5.4 using Luci succeded.

Now the router can connect to the 5Ghz ssid.

Thanks for the help

1 Like

I have had the exact same experience, very frustrating. The Router kept rebooting to the admin page. I “fixed” it by setting the repeater wifi to 2.4GHz only but it’s not a long term solution. So, my only query is the 4.4.60 kernel is available in normal betas and stable FW but this is only “fixed” in Kernel 5.4.

This is a big issue in my view, the System cannot be seen as ready for prime time out of the blocks. When can we expect to see a beta version of the FW that can be normally upgraded via the WebAdmin and still has the 5G capability please? And, does not need a full reset (i.e. preserves the settings). Currently Kernel 5.4>4.4.60 resets everythinng (I understand from a forum pos).

Thanks a lot!


We have fixed this in kernel 4.4.60 but needs a few days to release the firmware.

Awesome, thanks. Look forward to it :slight_smile: !

Hi, I downloaded and upgraded to 4.0.1 release5 but for me at least, the problem persists, in my test environment, my home network, where it connects at 5GHz, works for a while, then drops it, then reconnects, on reapeat. If I fix it at 2.4GHz it works just fine. I wanted to set it up on Auto so my Wife can take it travelling and just “use it”, without havign to select a specfic frequency. I guess I could leave it on 2.4GHz but that sort of defeats the point of “Auto”.

I also test it at work, which is conveniently close to an airport, so I have a perfect Travel Wifi scenario. There it works on Auto, as it chooses 2.4GHz every time. It might be jusy my home environment (too strong Wifi?).

Anyway, I saw another thread with the list of (4#?) ‘options’ it scrolls through (5Ghz, 2.4GHz) to get a “lock” on what I assume is the end-game, a frequency, but maybe add an option for try “X” times at the option at the top of the list and and if it fails after that many tries, THEN revert to the lower preference (but more stable) option.



Hi K.

I have the same issue, but only if the repeater and the wireless are both on the 5G. If I switch off the 5G wireless (only 2.4G wireless) and keep the repeater on 5G, it works as well.


Can you try the snapshot from Aug 10? It should have fixed the 5G repeater crash.

Will do but just wanted to check - do Glinet snapshots have all the functions and features of a beta build, because while I’m comfortable with betas I’m not that comfortable with command line installation and recovery steps if needed. Thanks :pray:

So far - seems to work. Haven’t seen the Slate AX constantly reboot. It auto connected to 5G. Thanks!


1 Like

What means few days? In August or more during next month?
I want to use a stable software which include this fix.

Sorry the firmware was called back because of another bug.

Ok, but you still working on a new firmware without the (Repeat modus) 5Ghz connection Problem

As it is taken back. We will fix the 5G repeater bug before release


t’s already released ? Cannot check at the moment.

Firmware 4.0.2 fixed the bug that the router crash when connecting to 160Mhz wifi.


perfect. Thanks for this fix.

I am on Release4 version 4.2.1 and the exact same thing is happening to me again. Connect to 5Ghz and the router endlessly reboots.