GL-AXT1800 Slate AX Unable to access plugins

I have never been able to access the list of plugins on my GL-AXT1800 Slate AX. When accessing the plugins page, a toast is displayed that shows “-2,Network unreachable”. I have updated to the latest stable firmware and saw same results, updated to Kernel version 5.4 and firmware 4.1.0 release 5 in beta as saw same results, tried connecting GL-AXT1800 Slate AX on a different network and same results.

Can you provide the URL that the plugins are accessed so that I can determine if it is being blocked by my network?

Brian Scheller

1 Like

In the top right hand corner of the Plug-ins page there is the Manage Sources button where you can click to see the repository address.

If you are using release firmware, you can just reset the firmware and it should work.

Usually this is due to problems in upgrade.

In my case, I’ve reset the router a few times already but it never worked. In 4.1 I encounter the same problem. The manage sources button is greyed out for me and clicking it doesn’t do anything:

Also like OP, the same problem exists on different networks.

image
image
I just download plugins both in GL.iNet Admin and LuCI
GL-AXT1800 Slate AX is repeater for GL-AX1800 Flint. Both are running Beta 4.1.0 Release5
Flint Has a Client Wireguard VPN and AdGuard running
:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

Thank you for the suggestion to resolve the issue. Unfortunately, it did not resolve the issue for me and I would like to explain the steps that I took.

The beta 4.1.0 release 5 was currently loaded so I started with that. I used the GUI to select the Reset Firmware option and still received the -2,Network unreachable after it rebooted. I then used the reset button on the side of the router and held it in until the lights blinked fast. After rebooting, I still received the -2,Network unreachable error in Plugins.

I then did a local upgrade to the stable 4.0.3 firmware. I again used the GUI to select Reset Firmware and after rebooting I still get the -2,Network unreachable error in Plugins. I then used the reset button on the side and held it in until the lights blinked fast. After rebooting, I was able to see a list of plugins but it quickly disappeared. I suspect the network had not connected when the plugins were displayed. I then received the -2,Network unreachable error.

So I tried two different reset firmware methods on two different firmware versions and none of the methods resolved the issue.

I am not able to look at the plugin sources as it is always greyed out.

Any other suggestions?

Brian Scheller

The sources button is always disabled, so I am not able to select it.

Are you doing clean installs, not retain settings and packagess? After install are you loading a Config file that was previous generated?

How are you upgrading and downgrading GL.iNET UI, Uboot, or LuCI?

Do you have a vpn running?

If they

This is a new unit so I am not restoring any configurations. If I remember correctly, the update to the stable firmware used retain settings but the update to the beta firmware did not use the retain settings option. Wouldn’t a hard reset throw away any settings? With the testing I did this morning, I used a wired connection for the router and laptop and did not bother to do any configuration after the firmware resets.

All upgrades have been via the GLiNet UI using the local update option after having downloaded the firmware from the GLiNet website.

I do not have a VPN running, but do have PiHole on my network which is why I originally asked for the URL used to access plugins so I could see if PiHole was blocking that URL.

This button will be disabled while trying to get the list updated. It can be clicked once the loading has finished.

As given above, all addresses start with fw.gl-inet.com/releases/, or you can add it to the whitelist?

I believe that I have finally tracked down the cause of this issue for me. I was able to ping fw.gl-inet.com so PiHole was not blocking that domain. I then monitored my firewall logs for the IP assigned to the GL-AXT1800. Looking at the Overview UI, it shows that the DNS server that is assigned is my router, but I noticed that 8.8.8.8 and 8.8.4.4 were be blocked in the firewall logs. I block external public DNS providers in an attempt to force use of PiHole. Once I disabled that firewall rule, I was able to get the list of plugins displayed.

Why is the DNS server listed on the Overview UI not being utilized to resolve the list of plugins?

Brian Scheller

1 Like

Looks like going back to 4.1.0 Release 5 firmware and changing the Override DNS Settings for All Clients to on, resolves the issue with the firewall rule to block access to public DNS servers turned on.

2 Likes