GL-AXT1800 (Slate AX): Wireguard client connect error (REKEY TIMEOUT)

Hi GLiNet community

I am encountering issues with my brand new Slate AX when trying to connect to a Wireguard server.

Namely, I am getting following repeating errors when trying to connect:
Tue Jun 21 03:03:15 2022 kernel: [x] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=REKEY-TIMEOUT
Tue Jun 21 03:03:15 2022 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-TIMEOUT SHLVL=2 HOME=/

and following as the device comes up:
Tue Jun 21 03:03:04 2022 daemon.notice netifd: Interface ‘wgclient’ is setting up now
Tue Jun 21 03:03:05 2022 daemon.notice netifd: wgclient (x): RTNETLINK answers: No buffer space available

The wireguard config itself is fine - I happen to own both a Flint and a Beryl, both of which I tested same config on Im using for the Slate AX.

Please do kindly look into this soon, as for me this is main use case for this device.

Thanks a lot

PS: Googling the error msg leads me to your Chinese dev(?) forum

Please check the time and timezone settings. Are they the same at both wireguard endpoints?

Hi Lupus, thanks for the quick followup! Appreciate it.

Hm, actually, the timezones were indeed different.

However the same error still persists, even after putting the Slate AX also into the right timezone/also on UTC. (also rebooted the router twice, removed and re-added the configs, etc. to make sure…)

Thanks a lot

Edit: Think this may be affecting more devices/users.
@hajjouj just now posted same issue on Flint after upgrade to 4.0.0 release 2
I am on 4.0.0 release 3, compiled 2022-06-03 18:19:56(UTC+08:00)

Please provide firmware version and build information.

Is it your own server you’re trying to connect to? If so, try PersistentKeepalive = 25
I’m not sure why that worked with my config but it did. I cannot connect to any PIA WireGuard servers at all whereas I am able to connect all 3 of my other GL-iNet routers to PIA wireguard via the app. Something is definitely up.

I am on 4.0.0 release 3, compiled 2022-06-03 18:19:56(UTC+08:00)

@RevelRob This unfortunately didn’t work for me either, although I run my own server

Today I just tried one wireguard config and it has this error. But it turns out it is the config’s problem. Maybe it is used in other devices or something.

I’m using the Agristan script to setup the server and client configs for wireguard (as probably do many, given popularity coming from OpenVPN)

This particular server is already being used with 2 other glinet devices (Beryl and Flint, both on a 3.x firmware) and its working fine. I generate new configs for every new device also.

Just to make sure its not an issue with this particular config in the SlateAX, I transferred over the wg config from my Beryl to Slate - where it didn’t work. Switched it back onto the Beryl, works again. (I’m c&p the manual config as to avoid fat fingering)

So unsure if its a problem with the same config being on two devices.

@alzhao Hi there, any chance you/the team can please have another look at this?

This bug kills the main use case for the router (as does it likely for many others, I suspect)

Thanks a lot

If you can send me a working config I could try.

I don’t have problem with my config.

Thanks for your help.

1 Like

Hi alzhao, sure thing, I will PM you the configs.
Thanks a lot!

Mine has also started doing this recently. Even tried a firmware reset to no avail.

Nevermind, I fixed it. I was previously copying and pasting the config but this time I downloaded the config.

A note to users where the wireguard server is Unraid: Download the config (don’t copy and paste) and upload the zip file into the Slate’s Admin Panel.

1 Like

I love the ‘use QR Code’ feature of the App. No typos, no wrong file format. Just works.

1 Like

Do you observe what format is not correct when doing copy and paste?

It’s a good question but unfortunately I couldn’t tell. I didn’t see any visual difference.

I should note that I was using android, copying from Unraid’s Wireguard VPN manager, and using the “paste as plain text option”. For various reasons, I also had to save into a Bitwarden secure note.

I later remembered how to do attachments in Bitwarden so I just attached the zip of the conf that Unraid provided.

1 Like

This fixes the issue! I uploaded the .conf and it worked

Strangest thing - the what I uploaded vs what I c&p into the field is 100% the same.
Tried it out a few times even to check.


hi, can you send the .conf info ? you clear the encry key, i want to find which is different from my conf.

@hilll did you got an reply? Do you figure out the difference?

I have the same issue here. I have tried copy and pasting the config, installing the app and using the QR code, going into VI and editing the config file, etc. I see nothing wrong with the config but I cannot connect to my self host VPN. My VPN is running on untangle but I’m fairly certain the problem is on the mobile router side.