GL-B1300 - VPN Policy - Netflix strange ISSUE

Hello,

i got this GL-B1300 router that works very well also with my Premium Account with NordVPN (Open VPN).

The speed under VPN is about 25 Mbit in down and 18 Mbit in up, so is quite good!

I use the VPN to route specifics IP subnet through the VPN and allow standard trafic for all the other subnets.

In particular i have 4/5 B-CLASS subnet like

83.12.0.0/16
85.19.0.0/16
97.112.0.0/16
104.98.0.0/16

using the VPN POLICY “Use vpn for these DOMAIN/ IP RANGE”

Everythink works fine except that i OPEN NETFLIX and i fall in a generic network error (not the same that i have when i’m covered by VPN “it seems that you are under proxy connection”, but is a generic network error like “cannot connect, verify your internet connection blablabla”).

So i thought MAYBE some of the ADDRESS i used includes some netflix services so I cleaned up all the list and i just leaved there A FAKE IP like: 99.99.99.99 with the expectation that only for that IP the VPN would have worked.

The result is that also with that configuration NETFLIX still doesn’t work with that generic error and it only happens when VPN POLICY is ENABLED. Of course with VPN POLICY DISABLED it doesn’t work because it says that i’m under VPN.

So i cannot achieve my goal that is: USE VPN FOR A SET OF IP RANGE and DOESN’T USE FOR ALL THE OTHERS (LIKE NETFLIX).

Amazon Video works correctly with the same setting.

Can anyone help me?

My hypothesis is that NETFLIX try to open many connections and the router performance cannot handle that inspection but it’s just an unjustified hypothesis.

Thank you

Netflix controls your dns too…and you are using dns of vpn…This is your problem and it is confirmed by displayed error.
I have had your same problem and I have solved using an italian vpn for my italian netflix that is excluded from using vpn in vpn policies.

1 Like

When policy routing is enabled, system DNS Settings are enforced, which may be the cause of the problem.
You can set DNS manually as required by Netflix and then Override DNS Settings for All Clients.

I’m italian so the situation is the same. I’m connected through vpn to an italian server (nord vpn) so i’m already that situation.

How am i supposed to configure DNS? Using google? 8.8.8.8 or whatever? dns i guess cannot be set with specific policy, no?

For you it was enought to connect to an italian server and it worked? How did you set up the “excluding netflix vpn policy”?

Grazie :slight_smile:

Which DNS do you advice to use? if i use common dns like 8.8.8.8 i will be still covered by the vpn? Thank you

DNS that you are using it’s dns of your vpn and you can not use alternative dns while vpn is running because vpn policies can only route traffic. You have to try another italian vpn server of your vpn service that netflix doesn’t block.

I have spent lots of time but it’s working fine.