VPN Policy and Android (TV) and Netflix

Wanted to make use of the “new” VPN Policy function on Mango V2.

I want to push the Netflix App on my Android (TV) boxes to a US VPN setting (via NordVPN) but only Netflix as otherwise my local provider apps won’t work as they need to be in local Australia.

I’m assuming for my desktop/notebooks I should be able to use just www.netflix.com as a domain to push through the VPN (as you have to explicitly got to that URL to get Netflix) however does this work for Android Apps too ?

I will have a play when I get a chance but any assistance before playing appreciated.

Worse comes to worse I attache my Android TV to Mango box and use the physical switch to go between VPN and non-VPN, but the WAF (Wife Acceptance Factor) on that solution will be MUCH lower :slight_smile:

Yes, this is what it supposed to work.

But I am not sure if netflix.com is the only domain for playing netflix videos.

You have to try and if it does not work we would be happy to debug and modify for you.

Netflix.com is not the only domain…I want to exclude netflix from my vpn with foreign ip but this policy is not enough…When streaming starts multiple https connections to more ip start…

You can try search the Internet and find more Netflix domain to add. For example

https://community.sophos.com/products/unified-threat-management/f/web-protection-web-filtering-application-visibility-control/46191/exception-rule-for-netflix-streaming

I’ve founded a list of 148 ip of Amazon streaming servers. I have tried to insert them on a single line in vpn policy exclusion using the ‘|’ like separator but the respons is invalid format…
How can I insert a list of ip in a single row?

thanks

I’ve edited the conf file in /etc/route_policy/domain_name/bypass_vpn to insert all 148 ip of netflix and now my esclusion of Netflix streamings is working right! :slight_smile:
The list of Netflix ip is here:
https://ipinfo.io/AS2906#blocks
@limbot
you must do the opposite of what I did: to insert the ip list in “use vpn for” after you have enabled vpn policies and unchecked “use vpn for all processes on the router”

@antifascista

This is a just a text file with all the ips in it? (Sorry I’m kinda new to some of this).

Can you upload a copy (to save me having to type) and might be useful to other users :slight_smile:

I assume I can then just use SSH and copy the file into “use vpn for” ?

Cheers.

Netflix_IP.zip (558 Bytes)
Copy an past the content of this file.
I’have used WinSCP to edit the conf file in /etc/route_policy/domain_name/bypass_vpn
https://docs.gl-inet.com/en/3/app/ssh/

1 Like

Thanks @antifascista
When I get some time I’ll have a go at it :blush:

The file to modify is manual-list.conf
I’m waiting for your feedback…:wink:

Can you please share the list again?

And I can update it via putty ssh to the router, right?

Netfilix_IP.zip (502 Bytes)

1 Like

Hi all,

I open this topic new, I was with the colleges already in progress but no success.
I can´t exclude Netflix or Amazon Prime not to use the OpenVPN connection!.
I get allways proxy error nevermind what we do…
We added all IP´s and so on, has somebody some options or advice??

Can nobody help with this issue ?

Add amazon.com to exclusion list together all the other IPs.

I did this and with the other 156 Netflix IP server but no success! also luochongjun was online no success.

List of IPs is dinamic. Go to the site that I have linked and add Ips that recently have changed.
For me is working fine. Sometimes I have proxy detected error but restarting streaming it’s ok.

what your router model.
You can try the latest firmware.

FW 3.100
and GL-AR750S-481

Any news, how we get further ??