GL-iNet AX1800 OpenWrt firmware

I bought an 1800AX modem, but I want to flash it for the first time. I wanted a guide on which file I should use for flashing?

If its your first time, i would advice not to install openwrt, but if you really want to follow the guide on official gl.inet youtube and instead of gl.inet image use solidus image.

For the Flint AX1800 the link given by @jeva is correct.
However it does have some issues and if its your first time i would also agree with @jeva and do not install.

Hej man, can you point me towards firmware blob from QCA which is causing the issue?

@jeva You mean the wireless blob right?

If so upstream-wifi-fw/ath11k-firmware/IPQ6018/hw1.0 at main · quic/upstream-wifi-fw ( is the blobs i am talking about version 2.6/2.7 have issues. 2.5 is stable for most part but not perfect.

other question, whats the benefit of having QoS and SQM QoS both in your openwrt image?

@jeva it allows end user to be able to use one or the other, as we all know both can’t be used at the same time so one will need to be uninstalled.

I am up for ideas on the best package setup for the images though.

I would say instead of having massive list of packages, most will benefit from simplicity of “Main useage” of router.

  • dhcp and dns
  • wireguard
  • adblock(which can add normal blocklist)
  • unbound
  • 5 interface(wan, wan6, (lan-admin, guest, iot))
  • usb3/2 mount point
  • automatic startup apps/scripts, auto reboot, scheduled led light config/reboot/timer
  • sqm qos(this actually benefit more those who have lower speed than 50mbps)
  • ddns

I personally would like if a separate tab would be just for ipv6.

Although i am not sure if its your image or openwrt in general have two different sections for static IPs;
one from ipv4 and other for ipv6.
I tried to coagulate into one but still it makes two different entries (attached in picture)


I think it’s better to keep vanilla OpenWrt to match the OpenWrt upstream rather than expand into another OWRT-based distro that includes such non-essential packages like ddns, adblock, unbound… it strikes me as a degree of moving in the same direction of other ‘offshoots’ like Gargoyle & could devolve into another complex overlay like the GL GUI.

Anyone who knows about those packages can always opkg install $package anyway.


Vanilla OpenWRT with all the basics like repeater working is all I could dream of!

1 Like

Repeating looks easy enough using stock + relayd, not that I’ve used it. There could be a more current method though like the HOW-TO fr MikroTrik. I think we’d both be happy with having full access to OpenWrt’s wiki, other’s tutorials, etc. if the image was kept as stock as possible without worrying about conflicts from extraneous package’s confs.

So there’s my 0.02USD.

No need for Relayd… Repeating is dumb easy with stock OpenWRT.

The main issue is proprietary WIFI drivers. You can read up a few posts if interested.

@solidus1983 : i guess i found a bug,
a week ago i activated NTP server. today i got welcomed by this.

module 'luci.ucodebridge' not found:
	no field package.preload['luci.ucodebridge']
	no file './luci/ucodebridge.lua'
	no file '/usr/share/lua/luci/ucodebridge.lua'
	no file '/usr/share/lua/luci/ucodebridge/init.lua'
	no file '/usr/lib/lua/luci/ucodebridge.lua'
	no file '/usr/lib/lua/luci/ucodebridge/init.lua'
	no file './luci/'
	no file '/usr/lib/lua/luci/'
	no file '/usr/lib/lua/'
	no file './'
	no file '/usr/lib/lua/'
	no file '/usr/lib/lua/'

In [anonymous function](), file [C]

In [anonymous function](), file /usr/share/ucode/luci/runtime.uc, line 133, byte 10:
  called from function [arrow function] (/usr/share/ucode/luci/runtime.uc:141:63)
  called from function render ([C])
  called from function [anonymous function] (/usr/share/ucode/luci/runtime.uc:141:64)
  called from function run_action (/usr/share/ucode/luci/dispatcher.uc:778:34)
  called from function [anonymous function] (/usr/share/ucode/luci/dispatcher.uc:1003:48)
  called from anonymous function (/www/cgi-bin/luci:39:12)

 `            die(ex);`
  Near here --------^

Things tried so far, tried installing luci-app-uhttpd--------- did not work.

although installing luci-compat package solved it.