Gl.iNet Beryl - Repeater Won't Connect - "Wrong Key"

Just bought a brand new Beryl. As in, it showed up Friday afternoon (yesterday). It absolutely will not connect as a repeater. I’ve tried connecting it to three different networks. The “join” button just turns gray and a spinning wheel comes, then a small window comes up and says “wrong key” and the “join” button goes back to green. Happens on 2.4 and 5GHz. I’ve updated the firmware to the latest stable, and tried the latest snapshot. Nothing seems to work.

Any ideas here?


Try installing the firmware in this post:

I do not work for and I am not directly associated with GL.iNet

3.203 is what I had out of the box. Upgraded to 3.211 because it wasn’t working, and then tried the 3.212 snapshot from there. I’ll downgrade and try again, but had it worked at first, I probably would not have upgraded.

Forgot to mention, I can only get it to even scan properly when I have my laptop connected via ethernet. If I’m connected wirelessly to the Beryl, it scans all the way up to 99%, then just stops, clears the progress bar, has an “Error:Time Out” window pop up, and the “Scan” button becomes green again.

If I’m on a wired connection to the Beryl, it will do the problem in the first post. This happens on firmware, 3.200, 3.203, 3.211, and 3.212. Tried all that is available for me to download.

Can you help to do this:

First, use your pc to conenct to the wifi directly and get the BSSID (mac address).
In your windows powershell use this command and you will find bssid. This will help to identify what is the vendor of the AP.

netsh wlan show interfaces

Then, if your UI scan goes to 99% and just stops, can you do this, ssh to the router and use the two command to scan. It will show scan list of 5G and 2.4G wifi.

iwinfo ra0 s
iwinfo rax0 s

It seems some wifi names and info break the UI.

Pls do the above and send me the output. I suggest you use 3.212 beta3 to do it so that we are at the same page.