GL-iNet GL-X750V2C4 Spritz 4G LTE being throttled after hotspot full speed allowance

I have a GL-iNet GL-X750V2C4 Spritz 4G LTE router. I’m using a Verizon reseller Sim Card with an APN of VZWINTERNET.

The router firmware version is 3.104-3.217

Under the modem manual set up options I have TTL set to 64 and MTU set to 1428.

The OpenWrt version is 19.07.8, r11364-ef56c85848

All was working well until I exceeded the carrier’s hotspot full speed limit of 5GB. After that, connected devices have slowed internet service. I tried iptable the entries for TTL in the firewall rules under LUCI but no change.

I have seen in the forum that in some cases the modem firmware may need updating. So I SSH’d into the router and executed the command to show the modem’s firmware version ( gl_modem AT AT+QGMR )
and it returned the following version:


Do I need to upgrade my Modem firmware or is there some other parameter I have missed in the set up?

I do have a GL-inet Mango GL-MT300N-V2 with the Iptable TTL entries and I can remove the SIM card from the Spritz, put it back in the phone, tether the phone to Mango via USB at it provides the connected devices full speed via hotspot even beyond the carrier’s limit. Ditto attaching the phone to my windows PC and using it as a hotspot.

Change TTL to 65


Change IMEI to match your phone’s IMEI

The IMEI was already set to my phone’s IMEI. The problem was the carrier throttling. I tried the 65 TTL setting with no speed change gained. I did however began to experiment with different TTL settings and I found for my tower and my carrier it improved significantly with at TTL setting of 87. I continued to experiment with addition TTL values but 87 was the optimum setting in my case.

1 Like

I’m having same issue. Using same IMEI has my Verizon hotspot router which the card was activated in. Also using MAC cloning. Still throttled. I even used Network Analyzer Pro app on my iPhone to get the TTL from pinging (114) and used that as my TTL for the Mudi! Still throttled.