GL-MT1300 Beryl - 2.4G WiFi not visible or not working

Can’t get either 2.4G Wi-Fi or 2.4G Guest WiFi to broadcast SSID, even tho its setup to do so. Pls help, thx!

Update: Occurs in USB tether, MR1100 in IP passthru feeding Beryl. Issue has been reproduced; I even did a factory reset, did not resolve Beryl not broadcasting 2.4G SSID. When I switch the MR110 to supply the Beryl via Ethernet, still in IP passthru – all is well and both 5G and 2.4G SSIDs are broadcast. Finally, and likely related, I get frequent disconnects with my LTE internet on a plan and location that has proven reliable, but only with the Beryl in IP passthru. Same USB tethering setup to my trust Mango, is fine as is Beryl using Ethernet connection. Is there a formal way to submit a bug?

So, when you put MR1100 in passthrough and let Beryl get IP from your carrier, it happens?

can you get the log?

Interesting. On my Beryl, with a Verizon Jetpack 8800L connected via USB (shows up as an Ethernet tether in the GUI) both 2.4GHz and 5.8GHz (on the Beryl) are working fine. I do turn off the onboard Wifi on my 8800L when tethering if that should matter. The 8800L also works fine in this manner with my Mango2.

I have an mr1100 as well, but am not currently using it as I don’t have AT&T anymore.

A clue…
Haven’t been using Beryl because of this problem, but just set it up with the OEM Netgear USB 3.0 to USB-C cable supplied with the MR1100 to pull logs and I’m not seeing the problem now. I then realized that I had been using a different USB3.0 to USB-C cable. When I switched back to that cable my issue returned, i.e. 2.4G WiFi goes down or at least stops broadcasting ssid. The problematic cable is a USB C to USB 3.0 Cable 3A Fast Charge with 56K Resistor;

BTW, MR1100 is tethered to and powered by the Beryl over the USB-C to USB 3.0 cable. Though it works fine with the one cable in my arsenal, I was hoping to use a shorter cable. Do I need to find one that does not have a 56K pullup? That may be difficult… Please advise, thx!

Logs, if still needed:

I have no idea why the 56k resistor is necessary for fast charging. Is it just a concept for selling?

Maybe just not enough power.

Per the specifications, USB Type-C plugs associated with the “B” end of a legacy adapter are required to have Rp (56 kΩ ± 5%) termination incorporated into the plug assembly. See:

Meant to protect legacy devices from overcurrent damage when being charged by a high power USB-C charger w/ a converter cable. When USB-C launched very few converter cables had the 56k resistor, virtually all of them do now as eric points out, it’s part of the spec. Is it possible for gl.inet to investigate? I suspect the old USB 3.0 to USB-C converter cable I have does not have the 56k, but I have no way to verify. -doug

I forwarded to hardware engineer to check.

Can I confirm again:

  • MT1300 is powered by the power adapter and type C able that comes with the router.
  • You connect MT1300’s USB3.0 port, to your MR1100 using a USB-A to USB-C cable. This cable is the problem and seems it is pulling high current from MT1300, causing wifi drops?
  • MT1300 is powered by the power adapter and type C able that comes with the router.
  • Yes
  • You connect MT1300’s USB3.0 port, to your MR1100 using a USB-A to USB-C cable. This cable is the problem and seems it is pulling high current from MT1300, causing wifi drops?
  • Yes and No, MR1100 is being powered by the MT1300 via 2 different USB-C to USB 3.0 cables; cable that works is old OEM Netgear cable that came with the MR1100. Cable that causes 2.4G WiFi to disappear is a brand new, short USB-C certified cable with 56k. I included Amazon link to exact cable in prior post. With this cable, 2.4G WiFi doesn’t come and go; it disappears altogether. Since this is a USB-C certified cable, I suspect the Beryl may be the problem, but I am not set up to test further or measure to see if the old Netgear cable also has 56k. Appreciate your help!

Hi alzhao, I got a new USB modem today, same issue as before with the 2.4G WiFi going away but this is much worse as the GL-MT1300 does not detect the modem at all.

Can you try another cable that worked to see if it can detect modem?

Also we did test internally using a cable with 56K resistor. And the cable does not affect the wifi of MT1300.

Thanks, I no longer have the Beryl, but Convexa-B on its way… So sorry can’t help testing

Seeing the same issue I believe on AR-750S
Edit: turned on guest 2.4G WiFi and now both 2.4G show up. Good for now.

So, I’m having this problem. No 2.4G or 2.4G guest Wi-Fi. 5G is fine. Except I have nothing else connected (no tether, SD card, etc). Doesn’t work either on network cable or in repeater mode. I got it to briefly work when I completely reset (deleted all settings). It worked once, but then when I unplugged power and replugged in it stopped working again (hard resetting each time is not a great solution). Anyway, anyone have solution?

Can you open a new thread about your issue?

Pls be sure to use the power adapter comes with the router. Better not use PD adapters.

For 2.4G, try to change to HT20, change channel, try a different pc or phone.

Yes, you can. I am using the power adapter that comes with it. I have messed around with all the settings (power, bandwidth, visibility, security, etc.). I can’t get it to come back unless hard reset (I’ve done that fix twice). After hard reset, I left it as it comes (no loading of software or configurations) but it only lasts one or two reboots (power cycles) before it goes out (of course, it says it is working but it is not).

And multiple devices (four different iPhones, two different iPads, Nintendo Switch and a laptop that only supports 2.4G) That’s how I noticed it wasn’t working to begin with. The other devices are connected to 5G normally. I don’t have a device that can see the 2.4G network.