GL-MT1300 (Beryl) Cannot change network settings in Luci

I installed luci. Luci had to change the existing wireless configuration (fig. 1). I haven’t changed any settings in luci or the web interface. The wireless network has not been deactivated, it works and I am connected via wireless, but the wireless network is shown as deactivated in the network overview - Network / Wireless (fig. 2). There should also be no stations connected. I cannot make any settings in luci.
With my GL-AR750S I can make many settings for 2.4 / 5 wireless network.
Does anyone have any advice?

Fig 1

Read this, it explains better than i can.

Basically you can’t use luci to set wifi because the router uses closed source mtk driver’s

Thanks for the answer.
So is there a difference between the wifi driver from the MT1300 and the AR750S?

Hey @rettungsman

The MT1300 is using a Mediatek Proprietary Driver, the AR750 is using an Atheros Open Source driver.

This is why we have full “compatibility” with Luci on the Slate but not the Beryl.


Hello limbot,
thank you for the answer.
Can you explain how i can easy change the wifi settings for different country. In some countries outside europe there are more or other channels allowed. For example channel 100 or 108 in South Africa.

1 Like

I believe ( and someone more technical should probably confirm) that you can edit /etc/config/wireless.

I have the same problem

I once tried to edit the file /etc/config/wireless, and I just wanna to change the country code, however it doesn’t works.

Thanks for reply.
It’s a shame that you can’t change the settings via luci or the web interface. I don’t know how to edit the file. So the travel router is useless to me. Maybe someone from tech can help?

If you are running Windows, SSH to the Router - GL.iNet Docs

I know PuTTY and WinSCP, but these steps are difficult for a normal user to carry out. The user must first determine the country code and wifi channel. Router cannot be used worldwide without further knowledge.

I agree and have put in my list of “improvements” to the developers.

I tried to change the country code via WinSCP. I was able to enter a different country code, but the settings have not changed.
For comparison, I tested it on an AR750S and I was able to change the settings.

Did you reboot after changing /etc/config/wireless?

Of course i did a reboot.

Any solution for change the country code?

What did you do exactly via WinSCP to change it? I changed the config via “uci” and it worked perfectly after a reboot. Changing them with iw didn’t do anything.

I did it like this manual:

Edit, change the country code, save and reboot.


I used ssh to change the country code following instructions I found from a user using google.

Today, I downloaded the 3.211 firmware ( and I also tried the beta 3.215 ) and did not keep my settings ( as recommended by GL-iNet ).

I thought : I haven’t changed firmware for a year so surely they have fixed the country code problem by now … at least in the BETA … at least it will be changeable in LUCI …

But no … it is still not editable so it is still useless as a travel router.
Worse :- I cannot even get back on my home network ( I’m sure it is because of this country problem )
And :- I now cannot find the post by the kind user who explained specifically how to do it.

Please, for the love of God, can you post how to fix this problem?

I won’t even bother to ask why you havent fixed it in firmware yet.

I have two Beryls, bought on Amazon UK and Amazon France.
Both arrived set to country code China and not hard but totally obscured by GL-iNet how to fix the problem.


Pls refer to this post to change country code