GL-MT1300 (Beryl) Easy Tether Config Issues


I was able to configure the first time using some tips here in the forum, but i tried to install luci and the software kind of broke i couldn’t access the dashboard of the router so i did a hard factory default reset and redo everything again.

Now it doesn’t work i have in my phone connection established but no internet access in the router.

Neither can i change the wan interface settings to add the Easytether to the WAN.

I’m not an expert on this but please help me reconfigure, i believe the issue could be on the ADB Interface but i ran this code already with no luck.

(openssl genpkey -algorithm rsa -pkeyopt rsa_keygen_bits:2048 -out /etc/easytether/adbkey)

Can you first upgrade to the latest snapshot?

This should have fixed some bug including installing software.

How do I do that? Should I look into a YouTube video? I guess there should be one explain how to do the snapshot update.

Just find the firmware for your model and do a general upgrade

I just did it and install luci is working great as of now.
I connect the phone and it said connection established but I saw that in the admin panel is requesting the 3g modem information. I need to do another adjustment in order to make easy tether work?

I finally got it to work, it works great!!! Now I just don’t understand why in the dashboard is not detecting it as Tethering it just appears 3G 4G modem like if I was going to connect thru that, but I’m already with internet connection, is there a way to make it recognize it as Tethering in the dashboard?

Hi, another update

I manage to work around luci and select WAN Interface and select the tap-easytether.

Still in the Admin Panel I don’t see like is receiving connection from any source instead is requesting to connect to 3g or 4g modem, but i do have internet access at full speed. Surprisingly amazing, way way way better than expected.

If there is any work around to make it detect that is getting internet from a source that way the LED will stay solid white instead of blinking Blue.

As the UI is not compatible to work with easytethering, so it does not show the correct info.

Can you give a little more details of the luci config for reference?


Of course see below

Once you log in to Luci go to Network and select Interfaces, that will send you this first screenshot.
I notice that you can select either WAN or Tethering or probably create a new Interface, once decided which one click on edit and go to the second screenshot below to se next step.

Once on Edit go to Physical Settings Tab, open the Interface select menu and select the adapter marked on the screenshot ( Ethernet Adapter: “tap-easytether” (wan)), then click save, go to the next screenshot below.

Now click Save & Apply, the router will reboot and you should have now internet connection with no issues at all, just don’t touch your phone leave it there connected. the GL-MT1300 (Beryl) wifi signal is surprisingly big enough to cover a full home. This device so far works amazing.

1 Like

Thanks for the infomation. Seems just need to add “tap-easytether” to interface name so that it can be discovered as tethering.


I already try that but still is seeing the phone connected as a 3g 4g Modem.

Still trying to figure that out in order to see the LED solid white as internet connected.


I just installed a Micro SD Card 32GB but is not being recognize at all in the network discovery.

Is there any special instructions to access it?

You need to download and install the file sharing. Log in to the router, go to applications, file sharing and install from there.

Nice, already got it to work, last thing missing is to make Beryl recognize Easy Tether as Tethering in the Admin Panel instead of recognizing the phone as 3G 4G Modem.


I just notice something i do see the GL-MT1300 on my network but once i connect the drive via the network drive it doesn’t see the Micro SD card of 32Gb I formated it to NTFS still dont see it

Are you using a version of the firmware from the stable release, or the snapshot? I was having problems with internal sd card reader and some cards but that was fixed in the beta 4 snapshot. If you haven’t already updated to snapshot beta 4 or 5 you should try one of them. Also make sure that ntfs-3g is installed to be able to write to it. See this link


I’m using the last stable one. Can you share the link on where to look for them? I kind of lost it.


Submitted an internal requirement to add this.

Fernando how many devices can connect to your network with easytether ?