GL-MT1300 Beryl - WireGuard client connection not working

Hi all,

I have just received my GL-MT1300 Beryl and tried to set up the WireGuard client to connect to a Windscribe VPN server in the US. I followed the instructions using the Windscribe connection configuration file.

The Beryl router appears to connect to the VPN but for some reason I cannot open any webpage on my connected MacBook. DNS is working (I am able to nslookup hosts, both on the Beryl as well as on my MacBook). Traceroute is showing the first hops in the US (both on the Beryl as well as on the MacBook).

I tested the configuration file in the WireGuard App on my MacBook Pro and it also worked without any problems.

On the Beryl router I get the following “wg” status:

root@GL-MT1300:~# wg
interface: wg0
public key: EAzfJ+SEVAkRiZ57V7T0C+w1+dDN3Fj4LkRYY7Fign8=
private key: (hidden)
listening port: 13200
peer: GxEk9eSOUsTVzoE07pe4YZRaROCQwW96cQokD38Pgkk=
preshared key: (hidden)
allowed ips:
latest handshake: 1 minute, 30 seconds ago
transfer: 27.75 KiB received, 20.08 KiB sent
persistent keepalive: every 25 seconds

The routing table also appears to be correct:

root@GL-MT1300:~# route -en
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface U 0 0 0 wg0 UG 0 0 0 eth0.2 UGH 0 0 0 eth0.2 U 0 0 0 wg0 U 0 0 0 eth0.2 U 0 0 0 br-lan

Can anyone help?


I believe someone is supporting you via email and hope this can be solved.

Was there a solution to this issue? Can’t get mine to work.

Try upgrading the firmware to openwrt-mt1300-3.201-0318.bin from GL.iNet download center

With this firmware (from what I read is due to be released on 31 March), I’ve been able to connect to StrongVPN WG servers.

1 Like