GL-MT1300 can't find wifi SSID or connect via ethernet

I’m having trouble getting my travel GL-MT1300 router to connect to a new main router in an AirBnB I’m staying at long term. When I run a wifi scan in the admin panel, the SSID for the main router is not coming up, even though I’ve been able to find and connect to that router easily on my laptop and phone. I’ve had no issue connecting this GL-MT1300 to other routers previously.

I have access to the main router itself (and can also access that admin panel). There is an option for hiding SSID on that router and it is explicitly disabled.

I attempted to MAC clone using the devices I was able to successfully connect to the main router with, but that did not fix the issue; the Beryl is still not showing the SSID in the scan.

I saw a similar issue for MT300N-V2s with users staying in hotels as noted below, but I’m not sure this is really the same situation based on the details of that network setup provided in these posts.
MT300N-V2 won't find hotel WiFi networks
MT300N-V2 can't find hotel wifi SSID, and solution - #3 by zhangh

I have an alternative option of an ethernet connection directly to the router. However, I can’t seem to get that to work either. The cable connection is established and recognized by the Beryl within the admin panel but there is no internet (even though there is a green circle next to the “Cable” field and the green network/globe icon is there). The protocol settings (DHCP) are correct and I can see the established LAN connection within the admin panel of the main router, where an IPv4 Address and MAC address are visible for the Beryl.

I have a basic/beginner understanding of all of this and would be extremely grateful for any guidance on how to resolve this as soon as possible.

Can you check what is the channel and encryption of the main router WiFi? Both 2.4G and 5G?

Thanks for the response. Just as an update, the Beryl was able to identify the 2.4GHz SSID and I have connected to it successfully. However, the 5GHz SSID still doesn’t come up and the ethernet connection still does not work.

For both 2.4GHz and 5GHz, the encryption is noted as “WPA/WPA2-PSK-TKIP/AES” and the channel is “auto”.

Can you try 4.1 beta? Someone in other thread report that it works better when using repeater.