I have GL-MT2500A (Brume 2) for couple of years already, and used it as a VPN Server on WireGuard.
When the latest 4.5.0 firmware became available, I tried to perform an normal ‘online’ update via web-interface 4.4.6 → 4.5.0, but it wasn’t successful (the update just didn’t progress). Then I tried to do it from the *.bin file, but also no success. As this point I just left this idea and the router was kind of working ok for some weeks.
However when I tried to add another Client to the WireGuard - it didn’t work and caused an error (pop up message on the top). So I’ve rebooted the router, but it has never booted since.

I then tried to recover it using the UBoot. It starts all well, I can access the firmware update page (, upload the file (router’s led are blinking during the upload), the process goes to 100% and all seems to be fine.
But as soon as I press ‘update firmware’ the following error message appears:

Something went wrong during update
Probably you have chosen wrong file. Please, try again or contact with the author of this modification. You can also get more information during update in U-Boot console.

I tried almost all firmware files that are available (GL.iNet download center) - from earliest to latest, but the error is always the same!
Please advice!!!

Can you try to flash the uboot itself before flashing the firmware? You can send an email to gl and they will replay to you with latest Uboot file.

Please note that flashing the uboot itself on different URL!! Check out the documentation!

1 Like

Thanks for advice! I’ve just sent an email to GL.iNet support. Hope they can provide the u-boot file with the instructions.

Wow. What a crazy coincidence. I’ve been repeating this exact same process and finally gave up. Typed in GL-MT2500 UBOOT FAILURE and here i find precisely my problem too - and just posted 16 hours ago. What are the odds of that?

So, yeah, UPDATE FAILED message consistently is where I’m at too. I’ll wait for an update on this thread to see if emailing support is the right way to go.

If you all guys are having the same update issue in the same model, then you should inform the support to pull it from the download page ! It seems to be a firmware issue for this particular model.

Do you have the same uboot version shown on the screenshot above ?

Yes. I have the same uboot version as shown in the OP’s screenshot.

fwiw, I’m pretty sure i updated the firmware via the admin page after i purchased it and that worked without issue. Which leads me to believe as you mentioned that it could be that the uboot software might need updating. Admittedly, speculation at this point.

I’m still going to hang back and see how support handles the OP’s request for help before I jump on the band wagon though.

To my request regarding the ‘uboot update’ Support said: “Your Uboot is not old and it can work”.

When I referred them to the ‘Update Failed’ again, they said it’s a warranty case, and didn’t offer any solution of how to revive the device.
I purchased my Brume 2 already 2+ years ago, so the warranty is over. They offered 30% discount if I buy a new device.

@spragues, you may want to try to mail them as well. As I don’t think it’s coincidence that we have exactly the same issue after the update to 4.5.0.


Well, first, good hear support got back to you relatively quickly. That’s welcoming in this day and age.

Second, i just emailed them too now to see if there can’t be something we can try and help debug the issue. I’m happy to be a guinea pig if it can help the general community.

After further review i note two things.

  1. On the above failure message it refers to getting more information from the U-Boot Console. Sure would be helpful to know how to access that. ie. whats the url for that puppy.

  2. on this page → How to get support quickly under section “Help, I’ve broken my router!” there is this note:

There can sometimes be problems when debricking with MacOS or Linux. It is best to try it from a Windows computer.

I have a Mac… so i dunno. Given i was able to access the uboot update firmware page on the router just fine from my mac you’d think my client wouldn’t matter but who knows. Also, the update failed immediately after pressing begin update which leads me to believe something about the file itself rather than the contents are the problem. This of course is just a hunch.

Anyway… that’s my brain dump so far. (sorry. :face_with_spiral_eyes:)

Interestingly enough Support got back to be yesterday and gave me an option to flash something called GPT on the router (um, nothing to do with ChatGPT. ha!) When i did that my MT2500A was no longer bricked. The current 4.5 firmware was also still present.

I asked them to reply to this thread with perhaps more details. If they don’t or can’t i’ll copy 'n paste their instructions here. Let’s give 'em a few days. Or, alternatively, you can try asking support directly about this option.

1 Like

Glad you got it back! Please share the details so others may benefit from it.

Hi @spragues, great news!
Strange that Support haven’t suggested this option for me, but rather offered a discount for a new device. I obviously don’t need a new one, if mine can be fixed. I’ll definitely ask them!:thinking:

In the mean time, could you please share the instructions, as I’d like to try to de-brick my Brume2 asap.

Easy does it. :face_with_diagonal_mouth: There was some context in my email to them that i was able to leverage what you reported on this thread. So i presume they were willing to offer some other possible things to try. If i was the first person to ask about this i would have probably got the same response as you. Strength in numbers!

And remember these are just ideas to try there are no guarantees. Perhaps i just got lucky. Who knows?

Okay so this what support emailed me:

Sorry for the inconvenience caused.​
Your router model is MT2500A with aluminium alloy shell, right? Did you try factory reset? You can press the reset button and hold it for 10 seconds, release it until you see LED flashing quickly.
And if you are able to access the uboot page, kindly pls refer to the following steps and see if it helps.

Then visit
upload the attached file
If successful, the router will boot up.
If failed, the webpage will show you an error message

Here’s the file to flash: (567 Bytes)
Unzip it before flashing.

i flashed this at I flashed the firmware at i unplugged and reset the router several times. The key for me was achieving a solid white led light. I got this after holding down the reset button while plugging in the power cord, waiting for 5 blue blinks and then releasing the reset button. You might have to experiment here as the timing here is a little subjective. What i did notice is if the router was slowly blinking blue (for an extended period) i was hosed and i couldn’t get to the standard admin page at

Getting that sold white led light is key. :slight_smile:

Let us know if this works for you.


I attempted to perform the GPT update, but it was unsuccessful. I put the Brume2 into UBoot mode and managed to accessed the GPT update page at:

Upload the file:

Everything seemed fine until I pressed ‘Update,’ but immediately after, the following error appeared, same as the firmware update error via UBoot.

That was probably the last option to recover the Router.

Anyway, I’ve already ordered a new Brume2, but what’s frustrating is that this one became a brick after an unsuccessful online update to the official firmware, without any custom modifications or file system experiments.

Regardless, perhaps this discussion will be useful to other users, as at least one person has managed to recover his router successfully.

Interesting. Yeah, when i pressed the Update button on that screen it didn’t fail (obviously) and the url changed to

Hmmm. I can’t speak to anything finicky about updating to the official firmware. That worked fine for me. In fact, that’s one of the first things i did upon receiving it.

I am having the same issue, I tried the update the firmware from 4.5.0 to 4.5.16 via the web admin, but the UI got stuck on “Downloading Firmware” and never changed, the router was still working. I closed the window and went to sleep. The next day the admin was still on that screen so I rebooted the router. It was still on that screen. I tried to update via uBoot, and the firmware update said successful in the browser, but it never rebooted. Now every time I try to update via uBoot, the update fails. Please help!

UPD, at times the uBoot updater says the update was successful, and the router is rebooting. It never leaves this page. The router never reboots to access the admin, only enough to get the uBoot tool. The light on the router stays on for about 10 seconds, then turns off, blinks once, then solid again for another 10 secs, then repeats indefinitely.

Looks a bit like hardware failure …
Can you send an e-mail to Our technical support can help you remotely. If it is a hardware failure, they can arrange an exchange.


It looks like that there’s something wrong with Brume2 routers in general, as we can see many of them become a ‘brick’ after the a standard update to the official firmware.
I ordered a new one, but I doubt that I will ever update the firmware on it, as it seems to be risky.

1 Like

I took the leap and updated my MT2500 to 4.5.16 yesterday. Works fine. So i guess i got the only one that works. :roll_eyes: Sure, updating firmware is always going to be slightly risky. And, yeah, there’s gonna be cases where it fails - it happens for whatever reasons.

Be thankful you got a pretty darn good responsive support system here.

1 Like

Ugh, I only had the unit for about a year and a half, and even if it’s over warranty it shouldn’t break so easily. These are the only devices on the market (that I have seen) that provide such a good package of price & (vpn) features. I suppose quality category would have to go down a bit now. :slightly_frowning_face: I guess the best thing to do with these is just update them for a year after you get it and not after. I have a Mango2 and that is pretty reliable, I’m using it now as a backup.