GL-MT3000 Beryl AX - FW 4.2.2 Regression in Wifi speed and channel width in 5GHz repeater mode

Updated to released 4.2.2 on Beryl AX and instantly lost ability of use repeater mode with channels wider than 20Mhz, which severely limits speeds in 5Ghz to a 1/4th speed as before.

Before 4.2.2 you had to do this: GL-MT3000 (Beryl AX) only allowed 20Mhz channels in repeater mode? to get 80Mhz channels working on repeater mode, but on 4.2.2 nothing that I’ve tried has been able to bring them back.

A few more pointers:

  • Fresh install (not keeping settings) to 4.2.2 doesn’t solve the issue
  • Downgrading to 4.2.1 fresh install enables 80mhz channels again when repeat mode
  • Upgrade previous 4.2.1 to 4.2.2 reliably reproduces the loss of 80MHz
  • This is only relevant for 5GHz. Even then, I disabled forcing 20Mhz on 2.4ghz but same problem.
  • WPA2-PSK/WPA3-SAE is used on repeater and main router

Please take a look into it


I got the same results

1 Like

Same problem repeating iPhone 13 Pro Max wifi 5 Ghz, downgrade to 4.2.1

1 Like

Same for me. no internet in wifi repeat mode
Does 4.2.2 2023-04-25 snapshot fix this?
Downgrading to 4.2.1

Upgraded with 4.2.2 2023-04-25 snapshot and seems to work ok

Same issue here… Back to 4.2.1 al least 80 mhz works :-/

I can confirm this bug as well.

I just received my AX3000 and 80mhz worked on 4.2.1; after upgrading I see the same 20mhz problem as reported here. Downgraded to 4.2.1 and it’s back to working with 80mhz.

Has anyone tried if current beta 4.2.3release5 fixes the problem?

@glinetlvr I just installed 4.2.3-0706-1688622794 (release 5) and it fixed the issue for me.