GL-MT3000 (Beryl AX) only allowed 20Mhz channels in repeater mode?

Just got the Beryl AX that’s looking solid so far. However it seems that it will only allow operation on 20Mhz in repeater mode, which severily limits the speed to about 100mbps in AX mode. Any way to change this to 40 or 80Mhz?


You need to make changes on the main router the beryl AX is repeating from. Also need to use WPA2-PSK/WPA3-SAE or WPA3-SAE

How is it handing heat? I know the slate ax had a lot of people saying it was running hot.

Seems just fine. It’s slightly warm to the touch but that’s it. There’s a fan on the bottom that you can see from the grill, but in my unit I haven’t seen it spinning yet.

Did that fix the issue, if it did mark as solved please

Changed the main router to 80Mhz only (a flint) but even then the repeater uses 20Mhz. At any rate, the common use case for me is when I’m traveling and I just won’t have access to main router settings so it is what it is.

You want to delete the previous saved network and create it again. Also might need to restart both routers.

My Beryl AX is also repeating from Flint on channel 153 and 80MHz. Also it needs to be a upper channel to get the full spectrum.

Some progress here. I think there’s actually not a limitation of 20Mhz when in repeater mode.

I did the following: setup the router with ethernet on the WAN side, and then all the wifi settings become unlocked. Setup wifi to the max of 160Mhz channels, and indeed when connecting from an ax client it connects at 2x2 with 80Mhz channels.

After this, I setup repeater mode again, and now the 80Mhz channel setting is preserved. Seeing 300mbps on repeater mode now which is fantastic.