GL-MT3000 (Beryl AX) repeater not working

Hi there,

Bought this really cute and handy travel router a month back to be used during my travel. I tested the repeater, and VPN functionality in Canada, and everything worked great.
While in India, I tried using the Repeater function - the router could not find any WiFI networks, while my laptop/phone could connect to the available wifi network, which is running on channel 5 @2.4 GHz. The router is working if connected via Ethernet.
I tried rebooting, enable/disable 2.4GHz Wifi. I am on 4.4.6 Rel 2.
With my 2.4 Wifi, I can see up to 11 channels. Currently this is in AUTO. I am not sure if this is a channel issue as my Wifi is broadcasting on Channel 5 which is available. I could not find the option to change the country in Lucy.

Please let me know how I can get the repeater functionality to work.

Changing country in luci: Flint GL-AX1800 wifi networks not seen by some clients - #41 by admon

Thanks. I don’t see country selection in advanced settings for me.

It might be different for the MT3000 then. :frowning:

As far as I remember, the WLAN in India is no different from that in Canada.
Unfortunately, I can’t tell you why it didn’t work.

Yet another wrong answer, @admon more then helping you are confusing users and polluting the forum…

To change country on MT-3000, go to Luci Admin and select menu Network / MTk WiFi where you can independently change country for 2G and 5G .


Thanks Meo. I can see the country option in MTK Wifi.

I found a hack to solve this. In Repeater > Repeater Options, I set the Mt-3000 to use the 2,4 GHz instead of the AUTO option and it was able to find the WiFi networks in range.


Hope this could help someone else with my same problem :wink:


1 Like

Awesome - This worked for me as well. I was able to connect with Auto before but for past few weeks I wasn’t able to scan any networks. Now I used the 2.4 option as suggested by @mfl and it worked. At least I’m getting 2.4 SSIDs