GL-MT3000 EasyTether Driver

Just got the early order of the GL-MT3000. I developed a quick way of going through multiple EasyTether drivers to find out if any driver would work on this router, & I found one that works flawlessly. Download EasyTether Driver OpenWrt 19.07.3+ Once you extract the zip file you’re going to want to look for the mediatek folder. Open this folder & use the folder that says mt7622. You have to know how to install the driver, & everything else in order for it to work. Wifi 6 also works on this router when using the EasyTether application…:sunglasses:


I cannot believe it.

1 Like

I was just trying different mediatek drivers, but once I got to the part when I typed in opkg install /tmp/filename.ipk, instead of it ending saying the driver is incompatible, it said complete. Then I continued with the necessary command prompts, root, etc, config, & so on, then went to Advance LuCi Network, interfaces, firewall setting, end so on. Basically I did what I normally do when I’m installing easy tether on a router I was surprised too but it works flawlessly. The real question is how & why is this easy tether driver working on this router? I know you said yourself that the firmware on this router is really from an older router just that it also has Wi-Fi 6 & a couple of other things. I have no idea if you like to see some pictures I’ll show them to you.

1 Like

I mentioned before that I found an application on the Google Play Store that actually works just like easy tether without installing the driver, if not better. The only thing is your Android device has to be rooted, yeah I know that sounds like something old back in the days, but you could still root some of these Android phones, for instance the S9 Plus 4G can be rooted at android 10. Once your phone is rooted go to the Google Play Store & install the application called VPN hotspot by My God Studio. This application only works on rooted devices. I purchased the router to just see that application also work on it but before trying the application, I installed the easy tether driver on it just to see what would happen & it worked. Try it, just install the driver that I mentioned earlier. Once I saw a connection established, thats when I knew it was working.

Once I saw that happen I thought I’d get lucky, so on the GL-AXT1800, I used the ipq806x EasyTether Driver, jus to see what would happen. After putting in the password, opkg update, opkg install /tmp/filename.ipk, it said complete at the end!!! I thought it worked too, because the driver installed, but after doing all of the other stuff, it never said connection established after plugging in the USB cord with easy tether launched. Just kind of strange how the driver actually installed but nothing else worked usually it’ll say the driver is incompatible & you won’t get that far.

It is actually the arch, complier etc that matters. I can try this out myself.

Apologies on digging up an old thread, especially as I’m new but were you ever able to test? I’ve been unsuccessful with mt7622 on the latest fw 4.2.3 release 5 and was curious if anyone had anymore luck with finding a driver to work with MT7981B? Thanks.

Sorry for the long wait I haven’t really been checking my messages on this site for a while but in order for you to find out the driver, you have to go into status system of the router in the browser, then look up what the Architecture is, once you get that, you have to go on to the easy tether site, & match that number with the driver. I never had that router that you have, but I do send clear instructions how to find drivers for routers that I’ve purchased.

That’s no problem and I appreciate the response. There’s currently no driver for the MT7981B so I will continue to wait and maybe pick up a MT-1300 for the time being. Thanks!

You would be better off getting the MT-3000. Its better then the MT-1300. The
MT-3000 has Wi-Fi 6, & it’s faster. Check the review on both of then, & compare which one is better. The one that you trying to find the driver for isn’t that great. If you don’t know the proper procedures of installing the driver & running the right command prompts, this whole thing is going to be a waste of time, because every time the router has a firmware update you have to do the procedure over again, which is no big deal if you know what you’re doing.

Nevermind both GL-MT1300 and GL-MT3000 now both WORK with the Pro version of Easytether (Amazon Store).

GL-MT3000 >> 19.07.3/mediatek/mt7622
GL-MT1300 >> 19.07.3/ramips/mt7621

GL-MT3000 is much faster as you suggested.
Thanks for your help!

How did you get this to work?

I dont see ‘tap-easytether’ listed in ifconfig on the router.
The connection and interface works on my Fedora laptop so something is up in the router.

Did you do anything to configure it?

After installation, copy/paste this as root on the router to configure your network with EasyTether.

cat << EOF >> /etc/config/network

config interface 'wan'
option ifname 'tap-easytether'
option proto 'dhcp'

Then reboot. It’ll show as you expected.

Sorry for opening again this thread. I just recently bought the MT-3000 and I’m trying to install the driver and make it work, the driver installs but can’t perform the line: easytether-usb. When I try the following error appears:

interface tap-easytether is used by another process (hotplug?)

On EasyTether it says connected but no internet access.

Hope anyone could help me out.

Ever get it solved? Mine does that too. A reboot usually takes care of it and good to connect again.

You’ve enabled USB debugging and all that? Can you do a easytether-usb -l?