MT3000 tethering Android Phone. Link Router tethering feature with EasyTether virtual interface/nic?

I own an MT300 and trying to share my phone’s internet with EasyTether.

I installed 19.07.3/mediatek/mt7622 firmware per this directions gl-mt3000-easytether-driver tutorial

I know my EasyTether Pro works on my phone because it works on my Arch and Fedora laptops.
It will show “Waiting for connection” and transition to “Connection Established” when I plug in.

root@GL-MT3000:~# easytether-usb
acquired interface tap-easytether
no device match (see setup wizard in EasyTether on your phone)
root@GL-MT3000:~# easytether-usb
interface tap-easytether is used by another process (hotplug?)
root@GL-MT3000:~# easytether-usb -l

However, no internet.
I found this thread which talks about changing the interface adapter for the tethering interface, no change.
reddit updated_easytether_setup

Have you allowed sharing via USB on the phone? Also, you wont get ipv6 on a lan.

Yes. Same phone works on my laptop directly.

Don’t use an app? Native should work fine as there’s no need for a tethering app. Android isn’t Apple. Beyond that it’s a provider issue.

I need to use the tethering app… Just changing the TTL might work, but from my previous experience messing with tethering android WONT forward/tether my VPN. Not sure if they check user agent as well or use DPI…

Plug phone in to my Fedora laptop or connect with bluetooth and it works great.
Plug phone in to the MT3000, shows connected (on both laptop and phone) but no internet.
It’s not a provider issue and not an issue with the phone. It’s something in the MT3000…

The router can ping google, just doesn’t forward the connection…
I guess the question is, how can I “connect” the EasyTether virtual interface/nic to whatever system the router uses for tethering. I dont see an entry in ifconfig for tap-easytether like I do on my laptop.

If you can ping Google then the connection is live. So it would be reasonable to suggest testing without the vpn. If the connection works without then it’s the vpn. If it doesn’t work then we know for sure it’s the gli. The only thing that springs to mind is gateway or dns fails at this point. And I know this sounds dumb but have you tried another usb cable?

I updated my post. I was wrong about pinging google with the router over the cell network. In fact, I dont even see the ‘tap-easytether’ interface in ifconfig like I do on my Fedora laptop.

I must have still had the wifi repeater up when I tested…

So easy tether is a requirement to bypass your providers lock on hotspotting?

In android have you tried activating USB debugging and USB default settings? Some phones require it for apps to use USB connections. I don’t think you can change server type in android for usb tethering. Only wifi hot-spot.

Maybe give the last section a look regarding the interface. Mine began working as soon as I had the pro version but this part was a little tricky and had more luck in the GUI option over the CLI option.

And some other notes I kept:

  1. Run command in terminal - easytether-usb

  2. It should output:

  3. acquired interface tap-easytether

  4. dropped root privileges


  6. now CONNECTED

  7. switching to background

  8. Go to Luci

  9. Network > Interfaces

  10. Accept if prompted re: Luci config

  11. Network > Interfaces > Add New Interface

  12. Name it, set protocol to DHCP Client mode, and select > Ethernet Adapter: “tap-easytether”

  13. Assign the interface to the WAN firewall zone in the Firewall tab of window

  14. Save & apply unsaved changes

  15. Reboot

Thanks!! That’s worked well! I’m writing this tethered.

Brief summary for anyone who wants it…

  1. Get Drivers
    If you don’t have them saved, get OpenSSL drivers for OpenWRT Download EasyTether drivers - EasyTether for Mac OS X, Windows, Ubuntu, Fedora and game consoles
    Copy file for 19.07.3/mediatek/mt7622 to the router’s /tmp folder via SCP.

  2. Install Drivers
    SSH into router and run this command…
    opkg install /tmp/easytether-usb-openssl_0.8.9-5_aarch64_cortex-a53.ipk

  3. Configure interface (can also do it steps 8-15 above in web portal)

cat << EOF >> /etc/config/network
config interface 'EasyTether'
        option device 'tap-easytether'
        option proto 'dhcp'
  1. Configure firewall (can also do it steps 8-15 above in web portal)
    vi /etc/config/firewall
    Press i to change edit mode to insert.
    You will see several entries starting with config zone. Find the one with option name ‘wan’.
    Add “list network ‘EasyTether’” to the area with all the other list network entries
    Press Esc, then type :wq

  2. Reboot

Does anyone know how to make the install or network/firewall modification persist after a firmware update? The configuration might remain, but I suspect EasyTether will be gone… we’ll see.

Does anyone know how to make it show connected under the tethering section of the gl-inet web interface? That would be a nice bonus.

1 Like