GL-MT3000 Hotel’s Captive Portal not showing

Again I am not able to get the hotel‘s captive portal.

I followed the standard steps described here:

The issue is, that even option 2 (Mac cloning) does not work (which normally works for me, if captive portal not working) - as it seems, that every new connection needs to pass the captive portal!

As I am staying for next 6 days here, maybe enough time to bring some light into this!

Hostname : GL-MT3000
Model GL.iNet: GL-MT3000
Architecture: ARMv8 Processor rev 4
OpenWrt Version : OpenWrt 21.02-SNAPSHOT r15812+885-46b6ee7ffc
Kernel Version: 5.4.211

Firmware Version : 4.5.0
Firmware Type: release8

1 Like

After checking other posts, I did additional checks:
directly connected to the wlan, I can ping cloudfare’s and access

But not possible to ping or open in browser once connected to wlan via router (without getting access to captive portal)

Log attached (6.6 KB)

Are you using AdGuard Home or intercepting DNS in any other way?
If this is the case, please disable it.

Additional make sure that you disable DNS Rebinding Attack Protection in Network > DNS

You might want to try this beta firmware as well:

All of these points are covered in the document and I configured accordingly.

I installed the version 4.6.0 and voila - it works now!!!
Is this the official 4.6.0 beta (so can I expect after official upgrade to next version, that this feature is still working?)

Thanks a lot!!!

At least I guess so.

Yes. We made this beta version with Open Source wifi driver that is more compatible.


I have a similar issue with my new GL-MT3000 when trying to connect to Xfinity wifi, it just shows “getting…” under the IP addresses and never obtains a lease with DHCP. I tried Mac cloning or factory default without luck. I’m able to connect to other access point but not xfinitywifi. Since this is a travel router I’m hoping that it can be friendly to captive portals since that’s the main reason I purchased it. Where can I get the 4.6.0 version? I did not see it online.

I just tried the 4.6 release2 firmware found in the other thread about hotel captive portal not working and I have some good news. With this new release I am able to connect to xfinitywifi and I get an IP address successfully. Then MAC cloning allowed me to bypass the captive portal after I have authenticated with my phone. It’s looking promising for the final release so far. Happy Chinese New Year! 新年快乐 !


Using my new GL-MT3000 for the first time at a hotel, I had no issues setting it up and logging in via captive portal. However, a few days later while still at the same hotel, a storm came and the hotel experienced a power failure. After power was restored, I could no longer reconnect with the MT-3000, but had no issues connecting from my iPhone and laptop directly to the hotel’s WiFi. I could no longer get access to the captive portal page from the MT-3000 using Safari on my iPhone in order to re-establish connectivity. I even tried resetting the travel router to factory settings to no avail. But then I finally got the captive portal page to pop up only after enabling and then disabling AdGuard from my iPhone using the Safari browser! I had never ever before enabled and used AdGuard! Now I’m a happy user and traveler. Very strange.

Firmware version: 4.5.16
Firmware Type: release3