GL-MT3000 using ZTE F50 5G USB wingle

Trying to use the Beryl AX (MT-3000) with the (fairly newly released) ZTE F50 5G wifi/modem. The F50 can be used directly when plugged into a PC, or standalone as a wifi AP if e.g. plugged into a power source only.
The Beryl unfortunately keeps disconnecting the modem with the following error message in dmesg repeating with incremental “device number”.

[   88.379827] usb 1-1: new full-speed USB device number 2 using xhci-mtk
[   88.531968] usb 1-1: not running at top speed; connect to a high speed hub

This results in the F50 resetting which means it cannot be used either in wired mode (tethered or modem) or even as repeater mode and connecting to the F50’s own Wifi AP.

Is there any way to fix this, or at least prevent the Beryl from causing a reset to the USB port? Would like to use the USB port at least as a power supply to the F50, without having to find a special non-data USB3 cable.

Any ideas or solutions would be appreciated. Thanks.

same issue need support

Maybe it is that the router cannot provide enought power.

But why cannot use as wifi repeater? You can plug it to separate power and use as ap, then use the router as repeater, right?

1 Like

The router is working without insert sim card when plug into gl-mt3000. To use as tethering mode sim card need to re-insert before plug
into gl-mt3000

Is there any specification on the power supplied by the USB3.0 port? (Do not see it listed on website or datasheet), however this could be a valid reason, that the F50 is resetting due to inadequate power supply.

Would prefer to use the F50 wired, but yes, could use as an AP, however using an additional power supply means one additional item to travel with, so would far rather connect directly to BerylAX even if only for power supply.

Unable to find command line option yet to disable data from the USB port, have a power-only cable on order.

Should be 5V1A maximum.

1 Like

Have you found a solution?

Now using a dual-port power supply to supply the router and F50, using the F50 as AP.
Waiting for a non-data USB cable and a power meter to be delivered, but given the rating on the F50 is “5V – 2A” it is probably going to end up being a power supply issue from the router.

Had mine working on tethering and I’m yet to experience disconnections. Didnt really do anything aside from checking the connections and settings (did change nanything_

This is the problem: Beryl AX MT3000 is only outputting maximum 4.8V without load, but extremely unstable, once F50 is plugged in voltage fluctuates down to 4.5V.

Long explanation:

  • Tried power only (data cables cut) USB cable from Beryl AX to F50, same rebooting issue of F50
  • F50 connected to any other computer USB port, power supply or portable power pack works correctly
  • F50 appears to draw ~0.25A once booted, spiking briefly to 0.65A shortly after startup
  • F50 connected to Slate AX works perfectly. (Slate AX has fairly stable voltage output of 4.85V when F50 plugged in). Same power supply tested on both Slate AX and Beryl AX
  • 3 different power supplies tested, all output constant 5.0xV (5.09, 5.05) as well as 3 different cables. All power supplies rated for 5V 3A. Beryl AX always outputs unstable low voltage at USB port, dropping on connection of load.

So this is definitely a power supply issue and the suspicion is the voltage drops too low causing the F50 to reboot. Given that the F50 with the Slate AX works correctly, this means this is an internal hardware problem on some Beryls (so far we have 2 reports with problems and 1 without).
Should these units unable to supply 5V be considered faulty and returned?

1 Like

Do you mean you have 3 MT3000 which has low usb voltage output but one did not?

No, one MT3000 (Beryl AX which has the problem) and one AXT1800 (Slate AX). I tested 3 power supplies on the Beryl AX, so the low voltage at the USB port is not from inadequate voltage supplied to the Beryl AX.
However both I and @lordsoros have this problem, but @troydeleon does not, so from this thread it seems that there are 2 units having a problem, and one not.
The 4.5V output is also below the 5% tolerance in the USB specification, even given inaccuracies of the meter (4.8V is already borderline).

I am tempted to try a capacitor across the USB VCC & ground to try smooth out the supply, but I do not want to destroy anything … yet.

1 week review of the setup. I’ve set it up as a backup for my ISP, with the Beryl AX connected via ethernet to my ISP’s modem. Still good but haven’t really used it more than an hour each time.

Using the Beryl AX supplied power brick and a 5G sim from the PH (Smart).

1 Like

Have you tried replacing the USB cable?

I’ve had the same experience. I just got my Beryl AX from Shopee (PH), and I tried to use my ZTE F50. However, it keeps restarting and won’t boot up.

Yes, multiple different cables between power supply and Beryl AX, and also multiple cables between Beryl AX and F50. One of the cables between Beryl AX and F50 was also a USB2.0 spec without the data pins connected (so power only).

The voltage at the USB port was also tested without any cables plugged in.
It would seem that the internal circuitry is resulting in a drop in voltage (stable 5V is supplied TO the Beryl AX), and the unit is unable to supply current loads of more than ~0.7A

Also, the Slate AX with exactly the same power supplies & cables worked correctly with the F50 plugged in, so it is almost certainly not a usb cable problem.

1 Like

I bought another modem which is the slate AX. I tried to use my ZTE F50, same experience it keeps rebooting the zte f50. what usb cable should i use? Thanks!

This is becoming more and more interesting:
My Slate AX initially was fine with the F50 (GL.iNet firmware), however I changed to pure OpenWRT and now the F50 will not complete the boot cycle on the Slate AX.
Trying an AR300 Shadow though (much older) and the F50 works (GL.iNet and and OpenWRT fork).

Got a Y-splitter cable (2x USB-A male plugs to 1 USB-C male) and this definitely allows the F50 to boot AND be seen as a connected device in the Beryl AX. More interestingly the power-only cable can be disconnected after full boot of the F50 and the F50 will continue to function … for an hour or so then it goes back into the boot loop.

@DioDelapaz you can either try a powered USB hub (may introduce other issues) or get a USB Y splitter power cable (effectively a powered USB “hub” for a single device). Some examples of the type you are looking for are here. Plug the power-only plug into a power supply and the other 2 into the F50 and Beryl AX.

This is still not the ideal solution, and given my experience with the Slate AX it may be adjustable via software, although overall I feel this is hardware issue and the units should be considered defective. @alzhao @Dipin any comments?

1 Like

For a 5G dongle, the power it consumes may increase when it is booting, have more data traffic or the signal is not good. So this should be a pure hardware issue.

Ok, I get that the F50 5G dongle probably draws higher current during startup, and I did not try many times with the Slate AX using both firmwares, however this still leaves us with:
GL-AR300 (Shadow) - USB2 spec - F50 works perfectly every time, multiple locations, multiple firmwares
Beryl AX (MT-3000) - USB3 spec - F50 never fully booted, multiple locations, multiple firmwares
Slate AX (AXT-1800) - USB3 spec - F50 appeared to work on official firmware, does not fully boot on OpenWRT fork (solidus).

USB3 spec by default should be able to supply more power than USB2 spec. And (after more consideration) why is VCC not bridged directly (internally) from input to the USB-A port? If I am supplying 5.05V input, then there should be 5.05V at USB-A, not the 4.8V measured, which I still suspect is the problem.
As you indicate though, this is most likely a pure hardware issue - so again I will ask: Does this mean the Beryl AX units (and maybe Slate AX also) with this problem should be considered faulty and replaced?

Overall this just seems like a huge backwards step with the newer hardware

1 Like