Gl-mt3000 v4.1.2 beta : quectel eg25-g with external USB enclosure

for 4.4.5 i modified here, then initially the router couldnt detect the modem even after one reboot

i switched to another usb modem that uses tethering then switch back to the external modem it then able to establish data connection (and set ttl works)

how long it can stay online, will monitor

update modem not so stable in this firmware, it goes offline randomly and becomes undetected by mt3000, maybe theres more configuration required but its out of my capability

Thanks for the reply and taking a stab at it. This is difficult not having my cell modem anymore. Is disappointing they removed signal strength info and set the default USB port to USB0 with this firmware so making AT commands is a pain. Have to select USB3 every time you issue a command and can’t easily set your antenna due to no cell signal strength info.

GL-iNET. Can you help us out with this? The previous firmware we were able to get things working after editing the file but now that file has very different content and we can’t use our modems anymore.

This issue will be corrected as soon as possible.

There are some issues with the qmi driver, which are being debug.

hi guys,
is anything going on in this topic?

I have Beryl AX (MT-3000) + GL M2 with T77W968 / DW5821e in it. When I plug the board to the router nothing shows up in Cellular nor Tethering.
Tried on firmware 4.2.3 and 4.4.6 - same result.

I can see it’s usb-modeswitch related - move the discussion here

T77W968 / DW5821e is not supported yet.

can you find solution for this

so how can i connect MT3000 with DW5821e, sir?

I think that with stock firmware it is not possible. I flashed pure OpenWRT v23 but still no luck. The modem is visible in mmcli but SIM card will not register.
I followed this tutorial. Apparently prepering the modem is also necessary see this but I don’t want to do it.
It’s already my second modem that I can not connect. I sold L-860 because it didn’t work with stock firmware. I though I will have more luck with DW5821e but it doesn’t look like this.
A couple days ago I bought another L-860 (in shipping) and going to sell DW5821e. Hope it will connect via OpenWRT v23.

1 Like

yeah, i try two ways of tutorial, then result is:

root@GL-MT3000:~# mmcli -L
/org/freedesktop/ModemManager1/Modem/0 [manufacturer unknown] model unknown

It was exactly same for me.
Try flashing pure OpenWRT v23 and downgrade ModemManager.

1 Like